Sonic Pi opening, the immediately closing

I have installed the Sonic Pi software in our school, and I am having an issue where a pupil level user goes to open Sonic Pi, it shows the splash screen, then immediately the splash screen disappears and the software fails to open.

Interestingly, when a pupil user opens it for the first time it works, but any subsequent attempt to open the software fails.

Pupil users have read and execute permissions for the Program Files folders.

If I run as administrator, it does work, but this is not an option for our pupil users.

I am running v4.0.3, I know there is an updated verion, but a network reinstall is a last resort.

Can anyone help?

Hi @DJMewes,

I recently collaborated with a school IT manager to fix a similar issue they were observing which was caused by a specific security constraint their school computers had set stopping Sonic Pi booting properly. I figured out what was causing it and released a fix which turned into v4.2.

Therefore, whilst network reinstall is a last resort, I highly recommend it as a likely solution to your problem. If you’re still seeing the same issue with v4.2 please do let me know and I’ll do what I can to get things working for your school.

I’m afraid Sam that after updating the software and testing, it is still doing the same thing, showing the splash screen, then nothing.

@DJMewes - that’s rather unfortunate. So sorry to hear that.

Would it be possible to grab a copy of all the log files found in the .sonic-pi\log directory (inside the user’s home directory) and then include them in a new GitHub issue over here: Issues · sonic-pi-net/sonic-pi · GitHub

Hopefully the logs will reveal where things are going wrong for you. Also, could I ask whether any previous version worked?

Also, @DJMewes - I know it’s an obvious one, but just checking you tried rebooting the machine after updating and before trying again?

Yes, I did reboot. We checked as the pupil user who was logged in and there were no log files. Would these be on the C drive anywhere? The exact same issue was happening on v4.0.3.

Please note I am not on the same site as the issue in question until Friday am now.

The log files should be stored in the user’s home directory.

We determine this on Windows by looking for the following in order:

  1. The path specified by the USERPROFILE environment variable.
  2. The path formed by concatenating the HOMEDRIVE and HOMEPATH environment variables.
  3. The path specified by the HOME environment variable.

Could you possibly let me know if any of these environment variables are set for the student login that is having issues? Also, could you try setting the environment variable SONIC_PI_HOME to a directory that is writable by the user and try again - and look within that directory for the .sonic-pi\log directory and the log files within? If SONIC_PI_HOME exists, Sonic Pi will use that to store all the user data regardless of the values of the environment variables described above.

@DJMewes I should add that getting Sonic Pi working on your school Windows machines is very important to me and if you’re happy to help diagnose the problem by gathering information and testing new releases, I’m happy to work as hard as it takes to get thing running - assuming we figure out what’s going on! :slight_smile:

Files have been uploaded to Github as requested

Thanks so much for this. I’ve responded over there to mention that it looks like you’re still running v4.0.1. The fix I was referring to that I hope will solve your issue is in v4.2 and I actually just released v4.3 which should be the version to try. Please send more logs if v4.3 doesn’t work for you.

Good luck!