Sonic Pi not loading past splash screen RPi 3

#1

Hi all

I received my first Pi in the mail last week. I got it for the sole purpose of running Sonic Pi, but as soon as I powered it up and tried loading Sonic Pi, the app kind of stops at the splash screen. After a few minutes of this, the splash screen will disappear and nothing else will open up, or I can click my mouse and the splash screen will disappear. Other times it seems like the Pi completely freezes and I have to reboot.

Through the week I have been doing research in what could be the problem, but I have yet to be able to fix my issue. Things i have tried include reinstalling NOOBS and Raspbian from scratch, “sudo apt-get update”, “sudo apt-get upgrade”, “sudo apt-get update && sudo apt-get dist-upgrade -y”, and I have followed a file called INSTALL-RASPBERRY-PI.md (/opt/sonic-pi) and attempted to compile-extensions.rb .

This last attempt is where things start going over my head in the command line terminal. In the file, "INSTALL-RASPBERRY-PI.md (/opt/sonic-pi), it lists several different packages to install. I did this, but when I get to the package called “libqscintilla2-8” and “libqscintilla2-dev”, this is what I get:

“Package libqscintilla2-8 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source
However the following packages replace it:
libqscintilla2-l10n
E: Package libqscintilla2-8 has no installation candidate”

When I received this message I installed “libqscintilla2-l10n” and found it is already installed and at the newest version.

Back to the INSTALL-RASPBERRY-PI.md file it tells me compile the server extensions by cd’ing to app/server/bin and running the ruby script compile-extensions.rb. When I do this I get the following message:
"Clearing ./…/rb-native/raspberry/2.3.0
Creating ./…/rb-native/raspberry/2.3.0
Compiling native extension/opt/sonic-pi/app/server/vendor/rugged-0.25.1/ext/rugged
Compile-extensions.rb:66:in ‘chdir’ : no such file or directory @dir_chdir - /opt/sonic-pi/app/server/vendor/rugged0.25.1/ext/rugged (Errno::ENOENT)
fromcompile-extensions.rb:66:in 'block in
fromcompile-extensions.rb:59:in ‘each’
fromcompile-extensions.rb:59:in

Then, INSTALL-RASPBERRY-PI.md instructs me to run the script “rp-build-app”. When I run this using the ruby command, it tells me "No Ruby script found in input (LoadError)

After doing all of this launching Sonic Pi still does not work.

Here is what my gui.log reads:
Detecting port numbers…
GUI OSC listen port 4558
port:4558 [OK]
Server OSC listen port 4557
port:4557 [OK]
Server incoming OSC cues port 4559
port:4559 [OK]
Scsynth port 4556
port:4556 [OK]
Server osc out port 4558
GUI OSC out port 4557
Scsynth send port 4556
Erlang router port 4560
port:4560 [OK]
OSC MIDI out port 4561
port:4561 [OK]
OSC MIDI in port 4562
port:4562 [OK]
Initially script completed
Using default editor colors
Launching Sonic Pi Server port 59
@@@@@@@@@@@@@@@@@@@@@@@
Launching Sonic Pi Server port 59
@@@@@@@@@@@@@@@@@@@@@@@
4558…
UDP OSC Server ready and listening
Ruby server pi d registered: 0
Waiting for Sonic Pi Server to boot

Critical Error! Could not boot Sonic Pi Server.
~
~
~
~
(END)

The remaining .log files contain no info.

Any help on getting sonic pi to run would be greatly appreciated!

#2

What are you using to power your pi? Some classmates and I ran into trouble with similar things because we powered it over Ethernet rather than a power supply, and it made the pi crash when we pushed it too hard.

#3

I am using the official RPi power supply. Also, I should mention that I have the model A Pi with no ethernet port and one USB port.

I wondered after the initial post if the model A was the problem and if I should get a model B+ to run Sonic Pi, and use my A model for a different purpose.