Sonic Pi Wont load past welcome screen

Hi all! I just got a new laptop and the freshly installed Sonic Pi 3.1.0. It shows the splash welcome screen for 5 to 10 seconds, then if I click the screen it disappears and sonic pi doesn’t load (if i don’t click the screen the welcome screen just stays there). If I try again it just does the same thing loading another instance of sonic pi in my task manager. I read other forums of this problem but didn’t see any solutions.

MSI laptop
Windows 10 PRO
16 gigs ram
nvidia 1060
8750 I7

I’ve ruled on resetting my computer, turning all antivirus off. I independently loaded supercollider. re-downloading and reinstalling sonic pi. Please help! This saddens me!

1 Like

This saddens me too!

Please could you let use know the errors in ~/.sonic-pi/log especially scsynth.log as this might point to the problem. (~ refers to your home directory).

I’m not as learned as other people might be. Can you explain to me how to access this log? where do I go?

got my trusty EE to help me find it.

Starting SuperCollider 2018-10-11 14:34:07

Device options:

  • MME : Microsoft Sound Mapper - Input (device #0 with 2 ins 0 outs)
  • MME : Microphone (Realtek® Audio) (device #1 with 2 ins 0 outs)
  • MME : Stereo Mix (Realtek® Audio) (device #2 with 2 ins 0 outs)
  • MME : Microsoft Sound Mapper - Output (device #3 with 0 ins 2 outs)
  • MME : Speakers (USB Audio Device) (device #4 with 0 ins 6 outs)
  • MME : Speakers (Realtek® Audio) (device #5 with 0 ins 2 outs)
  • Windows DirectSound : Primary Sound Capture Driver (device #6 with 2 ins 0 outs)
  • Windows DirectSound : Microphone (Realtek® Audio) (device #7 with 2 ins 0 outs)
  • Windows DirectSound : Stereo Mix (Realtek® Audio) (device #8 with 2 ins 0 outs)
  • Windows DirectSound : Primary Sound Driver (device #9 with 0 ins 2 outs)
  • Windows DirectSound : Speakers (USB Audio Device) (device #10 with 0 ins 6 outs)
  • Windows DirectSound : Speakers (Realtek® Audio) (device #11 with 0 ins 2 outs)
  • Windows WASAPI : Speakers (USB Audio Device) (device #12 with 0 ins 2 outs)
  • Windows WASAPI : Speakers (Realtek® Audio) (device #13 with 0 ins 2 outs)
  • Windows WASAPI : Microphone (Realtek® Audio) (device #14 with 2 ins 0 outs)
  • Windows WASAPI : Stereo Mix (Realtek® Audio) (device #15 with 2 ins 0 outs)
  • Windows WDM-KS : Speakers (Realtek HD Audio output) (device #16 with 0 ins 2 outs)
  • Windows WDM-KS : Stereo Mix (Realtek HD Audio Stereo input) (device #17 with 2 ins 0 outs)
  • Windows WDM-KS : Microphone (Realtek HD Audio Mic input) (device #18 with 2 ins 0 outs)
  • Windows WDM-KS : Speakers (USB Audio Device) (device #19 with 0 ins 6 outs)
  • Windows WDM-KS : Microphone (USB Audio Device) (device #20 with 2 ins 0 outs)

Booting with:
In: MME : Microphone (Realtek® Audio)
Out: MME : Speakers (USB Audio Device)
SC_PortAudioDriver: PortAudio failed at Pa_OpenStream with error: ‘Unanticipated host error’
could not initialize audio.

got it!, I disabled unused audio devices. I guess this worked because its working now!

2 Likes

Hello :slight_smile:
I have the same problem, and, as I’ve checked, the log file has got no errors. Can you explain how did you start this SuperCollider thing, please? I know nothing about it, but wanna try to do the same to make SonicPi work

Hi @janewithoutbrain,

sorry you’re having issues too. Could you share the contents of the logs so we can have a closer look to see what might be going wrong for you?

@samaaron thanks for such a fast reply!
After two reboots of my laptop, Sonic Pi has finally loaded, yay!

But in case I have this problem again I’ll describe the details. Everything starts exactly as Odul described it above, but even after I press “End task” for all the copies of Sonic Pi process in the Task manager, the app notifies me that its another copy is still running. Then it tries to restart the process and I see the welcome screen again; nothing happens.

Regarding the log files - most of them, including scsynth.log, are just empty. This is all I’ve found:

  1. server-output.log

Sonic Pi server booting…
Using protocol: udp
Detecting port numbers…
Send port: 4558
Listen port: 4557
Port 4557 unavailable. Perhaps Sonic Pi is already running?

  1. gui.log

[GUI] - Detecting port numbers…
[GUI] - GUI OSC listen port 4558
[GUI] - port: 4558 [OK]
[GUI] - Server OSC listen port 4557
[GUI] - port: 4557 [Not Available]
[GUI] - Server incoming OSC cues port 4559
[GUI] - port: 4559 [OK]
[GUI] - Scsynth port 4556
[GUI] - port: 4556 [Not Available]
[GUI] - Server OSC out port 4558
[GUI] - GUI OSC out port 4557
[GUI] - Scsynth send port 4556
[GUI] - Erlang router port 4560
[GUI] - port: 4560 [Not Available]
[GUI] - OSC MIDI out port 4561
[GUI] - port: 4561 [Not Available]
[GUI] - OSC MIDI in port 4562
[GUI] - port: 4562 [Not Available]
[GUI] - Init script completed
[GUI] - using default editor colours
[GUI] - launching Sonic Pi Server:
[GUI] - starting UDP OSC Server on port 4558…
[GUI] - UDP OSC Server ready and listening
[GUI] - Ruby server pid registered: 2272
[GUI] - waiting for Sonic Pi Server to boot…
.
[GUI] - Sonic Pi Server failed to start with this error message:
> Port unavailable: 4557, is scsynth already running?
[GUI] - UDP OSC Server no longer listening

[GUI] - Critical error! Could not boot Sonic Pi Server.

  1. processes.log

No pids store found here: D:/SonicPiPortable/Data/Temp/sonic-pi-pids
Exiting
Creating pids store: D:/SonicPiPortable/Data/Temp/sonic-pi-pids
Started [2272] [-] “D:\SonicPiPortable\App\Sonic Pi\app\gui\qt\release…\app\server\native\ruby\bin\ruby.exe” --enable-frozen-string-literal -E utf-8 “D:\SonicPiPortable\App\Sonic Pi\app\gui\qt\release…\app\server\ruby\bin\sonic-pi-server.rb” -u 4557 4558 4556 4556 4559 4560 4561 4562 [-] D:/SonicPiPortable/Data/Temp/sonic-pi-pids/2272

Looks like you already have a program that’s using port number 4557 running on your system. Perhaps the easiest way to possibly fix this is to reboot and try and start Sonic Pi again. Does that work?

Yes, it does, but after a few reboots in a row.
Anyway, thanks a lot! The product itself is amazing.