Raspberry Pi 4---Version 4.3 Error Message/Will Not Load


I was able to install Sonic Pi 4.3 but I am unable to run it—I’m using a Pi 4 32-bit with Version 10/“Buster” of Raspbian.

I updated Sonic Pi from an older version by downloading the package and installing it over the existing version—when I tried to run it from the terminal I got this error message:

/opt/sonic-pi/bin/…/app/build/gui/qt/sonic-pi: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6: version `GLIBCXX_3.4.26’ not found (required by /opt/sonic-pi/bin/…/app/build/gui/qt/sonic-pi)

Looks like it’s missing a file it needs to run? I did a search of the GLIBCXX_3.4.26 file to find out what it is but couldn’t really find anything specific enough to Raspbian or Sonic Pi to be helpful.

So I uninstalled Sonic Pi, did a full system update and upgrade and did a ‘clean’ installation of Sonic Pi 4.3 and am getting the same error message.

EDIT: one thing I did notice when I tried to do an upgrade:

The following packages were automatically installed and are no longer required:
erlang-base erlang-crypto erlang-syntax-tools libaubio5 libdav1d3
libqscintilla2-qt5-13 libqscintilla2-qt5-l10n libqwt-qt5-6 libsctp1
ruby-activesupport ruby-afm ruby-ascii85 ruby-atomic ruby-coderay
ruby-concurrent ruby-ffi ruby-hamster ruby-hashery ruby-i18n ruby-kramdown
ruby-memoist ruby-multi-json ruby-oj ruby-pdf-core ruby-pdf-reader
ruby-prawn ruby-prawn-table ruby-rc4 ruby-rouge ruby-rugged ruby-stringex
ruby-thread-safe ruby-ttfunk ruby-tzinfo ruby-wavefile sonic-pi-samples
Use ‘sudo apt autoremove’ to remove them.—Sonic Pi is Ruby-based I think—is this a clue/will the “sudo apt autoremove” solve my problem or is this unrelated?

Any further technical details about my Pi or its O/S that I’m using, logs etc to help someone help me can be made available upon request, might need a bit of help coming up with logs though.

Is it just a matter of getting a file into a folder and/or updating something Sonic Pi needs to run the new version (which somehow was not addressed when I did the update) or is there something else I need to do to get version 4.3 working?

Thank you in advance :slight_smile:

If you are trying the 4.3 install .deb file downloaded from sonic-pi.net then this is built for the latest Raspberry Pi OS which is built for Bullseye not Buster so you need to update your OS to use it.

Updated to Bullseye & tried to run Sonic Pi again from terminal, then I got the error message again, so I uninstalled Sonic Pi, figuring maybe the new OS needed a new install of Sonic Pi.

When trying to re-install it from the terminal, I got this error message:

E: Unsupported file ./sonic-pi_4.3.0_1_bullseye.armhf.deb given on commandline

So I downloaded the install file via the GUI and ran the install, I have no idea how to find logs for something like that, might be helpful, but it ended up with the same problem — hourglass followed by ultimately, Sonic Pi not starting from the GUI and then the same error message:

/opt/sonic-pi/bin/…/app/build/gui/qt/sonic-pi: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6: version `GLIBCXX_3.4.26’ not found (required by /opt/sonic-pi/bin/…/app/build/gui/qt/sonic-pi)

…when trying to run Sonic Pi from the terminal.

Wondering now what could be wrong with my system if it’s not the OS version causing Sonic Pi not to load?

I’ve sent you a dm rather than clutter up in-thread with this discussion.

1 Like