3.3.1_2 install doesn't run on Raspbian Buster/No bluetooth

I just ran a full update on the OS and downloaded the 3.3.1 deb file and installed that over the previous 3.1.1 (I think). It didn’t work, so I removed it and then installed 3.2.2_4 from the deb. 3.2.2 worked. So I tried to install 3.3.1 again. No go. I uninstalled them all again and did a 3.3.1 install from blank. Still no go.
The only feedback I can see if when trying to run it from the command prompt. I get:

/opt/sonic-pi/bin/../app/build/gui/qt/sonic-pi: relocation error: /opt/sonic-pi/bin/../app/build/gui/qt/sonic-pi: symbol qt_resourceFeatureZlib version Qt_5 not defined in file libQt5Core.so.5 with link time reference

I would actually be ok with 3.2.2, but I cannot get bluetooth audio working with it and I read about people using 3.3.1 and bluetooth magically working.

I’d MUCH rather have the bluetooth working (it works for other audio apps) than 3.3.1 if it’s a “one or the other” situation, since I’m using it in a classroom and they’ll find it much easier if they don’t have to tether to the tiny box and power cords/etc.
This is a pretty fresh install of RasberryPi OS, maybe 3 weeks old. I only got bluetooth audio working today (using blueman) and want a nice working master SD to copy for the other satations.
Thanks for any suggestions.

Hi Chris
In future it is better to report such issues on github rather than here.
I’ve googled the error you are getting and it appears to occur when you have mixtures of two different version of Qt on your system. I wonder if you re using the first version of the sonic-p 3.3.1 deb that was published on the sonic-pi.net site. A newer one which says

Requires Raspberry Pi OS
October 30th 2021.

This is the version of the latest OS.
I suggest you remove all installed sonic-pi versions using
sudo apt purge sonic-pi and then download and try this version the file name is
There may also be issues with a bluetooth speaker, although I have managed to use an Anker soundcore-mini connected via blue tooth with sonic-pi 3.3.1 It was a bit finicky to connect but worked OK.
If you have further questions or problems please post them as an issue on

Thank you. I have make a report on github.

1 Like