Rpi 400 ? ... Just tried it

pi@raspberrypi:~ $ sonic-pi
/opt/sonic-pi/bin/../app/build/gui/qt/sonic-pi: relocation error: /opt/sonic-pi/bin/../app/build/gui/qt/sonic-pi: symbol qt_resourceFeatureZlib version Qt_5 not defined in file libQt5Core.so.5 with link time reference
pi@raspberrypi:~ $ 

To add to the (admittedly not much) information in an earlier thread, one of the things we tried was building with the official sources on an RPi 400 (as well as various emulated Pis, most of which do not work nearly as well), and there were problems like getting the correct Qt version working, but that was many commits ago, maybe it’s worth another try to see if you still get the same error? Note that there are different versions of the operating system you can run on the Rpi, even if you stick with Ubuntu only, and that affects the library dependencies.

even if you stick with Ubuntu only,

Is Ubuntu the prescribed O.S… ?

Hi @hitsware - the supported OS for Raspberry Pi is their latest release which you can download here: Operating system images – Raspberry Pi

Good luck!

Thank You Sam !
Using 2 fresh uSD ’ s with the prescribed Rpi OS
from the Rpi ’ imager ’ , plus the .deb install from
the SPi site , I ’ m good to go on both a 4 B ( 4G )
and a 400 … I didn ’ t try ’ apt install ’ ( which I
would prefer ( but hasn ’ t worked ( consistantly))
lately )

1 Like

That’s great news @hitsware - enjoy!