No hassle Raspberry Pi 4 installation?

Hi! Long time no see In_Thread forum!

I am returning to Sonic Pi once more to play with @amiika Ziffers. To make musical exploration more fruitful, I am trying to setup a Raspberry Pi with 10’ screen amid my synthesizers and drum machines, with USB-MIDI out going into a thru box for message dispatching. I don’t really need audio output because I won’t be using the audio synthesis capabilities of Sonic Pi, just the timing mechanism and MIDI/OSC I/O.

However, I haven’t been able to find a binary of the latest SP version for the latest Raspbian image and compilation failed as well (more info on this later). I know that some of you are using Sonic Pi primarily on Raspberry Pi. Is there a recent build I could try somewhere or something to make experimentation easier?

I am using a regular Rasp 4 4GB, tiny USB soundcard + 10’ screen mounted and connected through pins.

Have a good day!

EDIT. Correct version will be posted tonight

Hi there. I thought the latest RPi binary deb on was Ok

You could try this which should be the same

purge the version you have installed using
sudo apt purge sonic-pi
then download and try installing this version instead

Oops wrong versio. I thin below is for Buster not bullseye. Will add alternative when I am home tonight

Thank you very much! I’ll wait for the new version and keep you updated about the installation process. I’ll install it on a fresh environment to start building from scratch.

Retried installing the deb version from (3.3.1_2) and got the following error:

The following packages have unmet dependencies:
  supercollider-server:armhf : Depends: jackd:armhf but it is not installable
E: Unable to correct problems, you have held broken packages.

I’ll continue to investigate.

3.3.1_2 should be the correct version. How are you installing it? Using dpkg will NOT bring in dependencies. From a terminal in the folder in which it is downloaded use sudo apt install ./sonic-pi_3.3.1_2_armhf.deb should work. Alternatively double clicking the icon and entering your pi password when requested should work too.

Another link to this version is at sonic-pi_3.3.1_2_Bullseye_armhf.deb - Google Drive
Let me know if you still have problems.

I am running sudo apt install ./sonic-pi_3.3.1_2_armhf.deb. The command is launched from a brand new OS image, using wget to download the .deb file beforehand. I have not tried using dpkg. I don’t really know what is going on, because the dependencies ARE installed. I’ve also tried to run the first steps of the compiling scripts, especially the script that is supposed to download all the dependencies through apt.

Can you try using qjackctl? It is installed by default but hidden on the main menu sound section. Use the main menu editor in the preferences section to enable it. See if you can start jack. Again I am in hospital visiting my Wife during the day so can’t give more details from here.

Jack is installed and running well. Is jackd the same thing as Jack2? The error I reported sooner in the topic it is complaining about jackd and not jackd2.

Sorry to be so long in answering but I am spending every day all day at hospital at present visiting my Wife.
see if this page helps you sort the problem

As mentioned in the Mac M1 thread, people have been working on this. “This” meaning hassle-free generation of packages in and for various environments. You need to apt-get some packages and libraries for the source to build, but that is not sufficient. For instance, try compiling Sonic Pi in a clean Raspbian Bullseye environment (e.g., in a virtual machine). The library libatomic1 gets installed. However, the first crash in the pi-prebuild script occurs when it downloads and tries to build vcpkg-tools: the option -latomic is missing when it tries to link at the end.

This is not even a Sonic Pi issue, but where should it be patched?

Sounds like a potential vcpkg issue to me. I’m yet to test it, but try updating vcpkg by first deleting the app/vcpkg, then modifying the to use VCPKG_BRANCH="2022.02.02" and see if that helps matters. It’s one version newer than the one we reference currently.

Note, this is the kind of developer-oriented discussion that’s best held over on GitHub. These forums are mainly for discussing the use of Sonic Pi rather than building it :slight_smile:

*VCPKG_BRANCH that is :wink: