Binary deb for Ubuntu 20.04 AND 20.1 for SP 3.3.1

I have created a binary deb file for Sonic Pi 3.3.1 specifically for Ubuntu 20.04 (amd64) . It may well work on closely related Linux OS, but this has not been tested.
Like the Raspberry Pi installation, it is built assuming that pulseaudio is installed (as is the case for a standard Ubuntu 20.04 desktop install), and by default will use this for selecting the output audio path, using the Ubuntu sound tab in the settings module. However the internal workings of Sonic Pi remain based on Jack, and, provided that you select a sound output device that is NOT currently the default pulseaudio output device, you can start Jack using the QjackCtl interface, and configure your device for optimum sample rate, and latency, and use it as for previous versions if you need better performance.
I have tested the installation fairly throughly on a virtual Ubuntu machine, and it has worked well.
Some release notes are included with the download. Please read them before use, particularly noting the need to add your ubuntu username to the audio group as detailed.

The download link is here

EDIT just tested it on Ubuntu 20.1 and it runs there as well!

5 Likes

Thanks so much for this Robin! Without your work support for Raspberry Pi would very much not be where it is today.

hi @robin.newman

On a fresh Ubuntu 20.04.3, i get this issue :

sudo dpkg -i UbuntuSP3.3.1BinaryDeb/sonic-pi_3.3.1_2_amd64.deb 
[sudo] Mot de passe de nlb : 
Sélection du paquet sonic-pi précédemment désélectionné.
(Lecture de la base de données... 172013 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../sonic-pi_3.3.1_2_amd64.deb ...
DĂ©paquetage de sonic-pi (2:3.3.1) ...
dpkg: des problèmes de dépendances empêchent la configuration de sonic-pi :
sonic-pi dépend de libatomic1 (>= 4.8) ; cependant :
 Le paquet libatomic1 n'est pas installé.
sonic-pi dépend de libqt5concurrent5 (>= 5.0.2) ; cependant :
 Le paquet libqt5concurrent5 n'est pas installé.
sonic-pi dépend de ruby ; cependant :
 Le paquet ruby n'est pas installé.
sonic-pi dépend de supercollider-server ; cependant :
 Le paquet supercollider-server n'est pas installé.
sonic-pi dépend de sc3-plugins-server ; cependant :
 Le paquet sc3-plugins-server n'est pas installé.
sonic-pi dépend de erlang-base ; cependant :
 Le paquet erlang-base n'est pas installé.

dpkg: erreur de traitement du paquet sonic-pi (--install) :
problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.24-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1ubuntu1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.64ubuntu1) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.1-1) ...
Des erreurs ont été rencontrées pendant l'exécution :
sonic-pi

It seems that a lot of dependencies are not installed.
Cheers

Dont use dpkg to install use apt. This will pull in the required packages.
sudo apt install ./pathtodeb

Hi @robin.newman

Oh i’m a bit sorry… Of course you’re right

In case someone makes the same error as me, this is a solution.

nlb@dellux:~/Téléchargements$ sudo apt install ./UbuntuSP3.3.1BinaryDeb/sonic-pi_3.3.1_2_amd64.deb 
[sudo] Mot de passe de nlb : 
Désolé, essayez de nouveau.
[sudo] Mot de passe de nlb : 
sudo: 1 saisie de mot de passe incorrecte
nlb@dellux:~/Téléchargements$ sudo apt install ./UbuntuSP3.3.1BinaryDeb/sonic-pi_3.3.1_2_amd64.deb 
[sudo] Mot de passe de nlb : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'Ă©tat... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 sonic-pi : Dépend: libatomic1 (>= 4.8) mais il n'est pas installé
            Dépend: libqt5concurrent5 (>= 5.0.2) mais il n'est pas installé
            Dépend: ruby mais il n'est pas installé
            Dépend: supercollider-server mais il n'est pas installé
            Dépend: sc3-plugins-server mais il n'est pas installé
            Dépend: erlang-base mais il n'est pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).

so i did apt --fix-broken install and everything is working !

Again, sorry for the inconvenience

Cheers

NP I got it wrong first time too :slightly_smiling_face:

Successfully installed on Debian 12 (Bookworm).
Just needed a little apt --fix-broken install
Thanks for this linux package.

Oh man! Thank you so much for this… It’s the only 3.x version that ever worked on my Ubuntu machines!

1 Like