E: Unsupported file - Can't install Sonic Pi on Raspberry Pi


I have a Raspberry Pi 400 everything Is updated and everything the latest.
When I download Sonic Pi manually it installs but nothing happens after that.
When I try to install via Terminal it says:

E: Unsupported file ./sonic-pi_3.3.1_2_armhf.deb given on commandline

What does this mean? How do I get Sonic Pi to work on a Raspberry Pi?

Thank you

Are you typing
sudo apt install ./sonic-pi_3.3.1_2_armhf.deb
To install it? That should work.
Alternatively you can double click the icon of the downloaded .deb file and follow the instructions to install it.

Yes I
sudo apt install ./sonic-pi_3.3.1_2_armhf.deb

E: Unsupported file ./sonic-pi_3.3.1_2_armhf.deb given on commandline

When I double click and type my password it says “loading cache” and then nothing happens.
Sonic Pi doesn’t installing at all. I have a file with the name “Sonic Pi” under programs but nothing happens when I click the icon.

Should I install another OS maybe? Thank you

You need the very latest is for this file released January 28th 2022
What does cat /etc/os-release
Show you?

I would also try
sudo apt update
sudo apt purge sonic-pi
Before trying to install again

You must be connected to the internet while you install so that the extra packages can be pulled in.

Thanks alot for your answer!

I formated the raspberry pi and installed the latest Bullseye 32-bit.

I tried to install on Terminal but It got the same error: E: Unsupported file ./sonic-pi_3.3.1_2_armhf.deb given on commandline

However! When I downloaded it manually it worked like a charm. Thanks for helping me!
I will get into this and upload some tests later. :grinning:

Great. Glad you got it going. Enjoy Sonic Pi.