Installation v 4.3 on raspi4

Just tried installing sp 4.3 on bullseye armhf 64 (raspi4).
Version 4.2 runs fine but 4.3 installation failed with the following error msg;
The following packages have unmet dependencies:
supercollider-server:armhf : Depends: libscsynth1:armhf (>= 1:3.11.2+repack) but it is not going to be installed
Depends: jackd:armhf but it is not installable
btw 4.3 runs fine on my mac.

Strange. I’ve just checked the install on an SD card with the latest RasberryPI 64 bit OS (making sure that it did not have supercollider or scsynth installed before hand) and it worked fine.
Is the 64 bit OS on your Pi4 up to date. sudo apt update and sudo apt upgrade
I assume you are using the package file sonic-pi_4.3.0_1_bullseye.arm64.deb
I assume you were connected to the internet as you installed it so that it can pull in the extra packages required.
It should work if you double click the file icon and then insert your Pi password when prompted.
Alternatively open a terminal in the folder where the file is downloaded and type
sudo apt install ./sonic-pi_4.3.0_1_bullseye.arm64.deb

If you still can’t get it working, please move this to Issues · sonic-pi-net/sonic-pi · GitHub or direct message me on this site. We prefer not to clutter up in-thread with debugging/problems like this.

I got ( the same ( or something similar ) )
with RPi 400 32 bit OS … ( a few days ago )
With a second try it worked fine ??? …

Hi Robin. Problem solved. I accidently picked up the wrong version from my downloads: armhf instead of arm64. Everything runs fine.

Glad its sorted. I thought it rather weird what seemed to be happening. Makes sense if it was the wrong version.