Sonic Pi 3.2.2 Critical Error - "Could Not Boot Sonic Pi Server"

Installed Sonic Pi on a Dell that is up-to-date, but when I try to open Sonic Pi I get this message. Tried uninstalling and installing again but the same error occurred? I know there are other topics about this on the forum, but I can’t seem to understand what the fixes that are discussed are.

You don’t say which OS you are using on your Dell. Because you have 3.2.2 installed I guess it is some flavour of Linux, as there are more recent released versions for Windows (which generally runs on Dells. It is better to report such issues on Issues · sonic-pi-net/sonic-pi · GitHub version 3.2.2 is a Linux release which generally requires some configuration of the local sound setup. Please give further info on github.

1 Like

Thanks Robin, I reposted it on the github link you sent. Is there a later version than 3.2.2 that would work better on PCs? I didn’t see any?

If you are running Windows 10 on your PC then you can download version 3.3.1 from
You can also become a supporter of Sam Aaron on Patreon whereupon you can have access to SonicPi v4 beta7 which contains significant improvements. Patreon