I can't install sonic-pi in raspberry pi

I am trying to install sonic-pi in raspberry pi OS in a virtual machine since I noticed sonic-pi existance in the system and then tried run it, but it returned a boot error, from that on is just a journey of failures to install sonic pi with more informations on: building issues at raspberry pi os · Issue #3293 · sonic-pi-net/sonic-pi · GitHub

I am not sure if that problem is just happening because I am running raspberry os in a virtual machine, but despite I am already using sonic-pi on windows I really want to know how to solve this issue so I would know what to do if I get my hands on a raspberry pi board. I would be able to push music to other raspberry pi boards.

Also, I am newbie in linux and I run on a lot of installation problems and even trying codes I see on internet I can’t get them working, some I fixed by accident. I think fixing this problem should make me understand more about linux, but I ran out of ideas and topics to search. please help.

in short I already tried:

  • sudo apt-get install sonic-pi ,
  • installing from sonic-pi.net ,
  • git clone https://github.com/sonic-pi-net/sonic-pi.git

my system is Debian GNU/Linux 11 (bullseye)

if you ask the errors returned, I will send here, I didn’t put it right away so the topic wouldn’t look like a monster like the github issue I posted here