Which Linux works?

Let me ask positive: On which Linux brand does the new version of SP work? For me (may be for some others) it’s not a problem to install any Linux version to run SP with.

I just found threads with … not working …

I’m afraid there is no official support for Linux installers due to lack of resources to develop and maintain. However the build process has improved and it is now much easier to use.
However, the latest version of SP (4.5) has made the switch to using pipewire to underpin the sound system, and this is not always available particularly on older linux distributions. It also now uses Qt 6, again which may need newer distributions.
I have used the build scripts on ubuntu 23.10 and Debian 12 for SP4.5 and they work well.
It is also worth looking at the flatpak installer for version 4.5
One thing to note is that version 4.5 requires a 64bit system and will not run on 32 bit, which earlier versions were able to do.

Thanks for your hints.
I have tried first Sonic P 4.3 on Ubuntu 22.04 - Google Drive
in the past without success.
Actually I have installed manually the dependencies listed at github (not all successful) and installed pipewire following How to Install and Configure PipeWire in Linux - Make Tech Easier.
Tried Sonic P 4.3 on Ubuntu 22.04 - Google Drive again → works!
I am not sure but I think the manual Installation of pipewire and wiping off pulseaudio was the key to success?
Surprisingly I have ver 4.3 AND ver 4.5 running? Both without audio output? The 4.3 version is the flatpack-version.
Might be solvable?
Thanks anyway!

What does the Pipewire graph look like?
It could be that the connections are not made automatically.

I am on an ubuntu brand (Linux Mint Mate 1.26.0 21.3 Virginia 64 bit). I installed the necessary tools to run Sonic-Pi 4.5 as there are Qt version 6.6.2. and pipewire and some adds (pipewire-pulseaudio and the wireplumber.service). The usual sound sources work aterwards as they did before.

Afterwards installed Sonic-Pi v4.5.0. I run it as root and do not get any sound.

With qpwgraph I documented by screenshots the connections between the different sources.

1st there are the sound modules without any active sound sources /home/bb/Dokumente/PipeWire Graph Qt GUI Interface-start.png (These my differ at another hardware.)

2nd if I start a youtube video PipeWire Graph Qt GUI Interface+youtube

3rd with an example running on Sonic-Pi (firefox/youtube cancelled) no sound at all

4th an additional youtube video running with sound to hear, but no sound from Sonic-Pi.

I made/tried a connection from the different SuperCollider outputs without success, say no sound. (supercollider ist schon die neueste Version (1:3.11.2+repack-1build1)

There is no active sound source of Sonic-Pi to see (and to hear). I think this is a very fundamental problem with the Sonic-Pi Linux-Version. Obviously Sonic-Pi is not interfacing SuperCollider?

I could install Sonic Pi v4.5.0 on Raspberry 400. Audio works. For comparison I add a screenshot

I have shifted the items to get it neatly arranged.

Does the Sonic Pi visualiser show anything?

For reference, here is my setup:

It should work if you drag connections between supercollider out_21 and playback_Aux0 and between Supercollider out_2 and playback_Aux1 You can have two sets of connections to the same ports. as per "Davids-Music_Lab answer.
You don;t see anything labelled Sonic Pi because it is SuperCollider which performs the audio generation. If when you play something is Sonic Pi you see activity on the Scope display then Sonic Pi is working, but is just lacking routing of the audio which you do in qpwgraph

By default SP is set up to connect to the speakers in an HDMI monitor, For anything else you manually connect. It is possible to write code to automate the connections once you know what you want.

Thanks.
The Sonic Pi visualiser shows activity.
My HTML Monitor is without speakers.
I already tried a connection to my (working) output with any of the outputs of SupeCollider in advance.


Does not work.
To make sure that the output works, I connected the output of a youtube video. I hear youtube, but not the running prog in Sonic Pi!
I tried the internal speakers of my workstation as well - youtube works but not SuperCollider/Sonic Pi.
as a rule I work with an USB audio interface and/or an USB mixer - youtube works but not SuperCollider/Sonic Pi.
An interesting question to confirm a proper Sonic Pi v4.5 on any Linux : Who is running a Sonic Pi v4.5 on which Linux successfully? Thanks

Various points. Can you see if the scope in Sonic PI shows any activity when you run a program? If not then the problem is something else, although you do need an audio output device connected in order to hear anything. Secondly only the first two outputs are relevant unless you explicitly redirect the sound to other ones in the Sonic PI program you write, using the with_fx :sound_out_stereo wrapper in Sonic Pi.
Third did you build your 4.5 version from source using the suppled scripts, or did you obtain it by other means?
Fourth do the logs (in ~/.sonic-pi/log folder) show any problems. They can often be a good indicator of anything not quite right.
As far as linux goes I have successfully built from source for latest versions of Ubuntu, Debian and Raspberry Pi OS, all of which are geared up to use pipewire. For previous versions of linux OS versions 4.3 or previous may be easier to get going.
Have you tried the flatpak install for version 4.5? That works OK on the latest debian and ubuntu too.
I notice also that you say you run Sonic Pi as user root which is a bit unusual.
Sorry the above is a bit rambling…just as ideas occurred to me.

As i pointed out there is activity in scope when I start an example - but as already said no sound.

“I notice also that you say you run Sonic Pi as user root which is a bit unusual.” I do not explicitely. When I start Sonic Pi from Menu there is a message in the item in the Leiste (“als Systemverwalter”), I run the German version of Mate. Mate has a list of icons in the bottom bar. I think I translated wrong? I did/do not understand this message.

~$ ls -l .sonic-pi/log
insgesamt 36
-rw-r–r-- 1 bb bb 7822 Mär 30 10:25 daemon.log
-rw-rw-r-- 1 bb bb 0 Mär 30 10:25 debug.log
-rw-rw-r-- 1 bb bb 5065 Mär 30 10:25 gui.log
drwxrwxr-x 12 bb bb 4096 Mär 30 10:25 history
-rw-rw-r-- 1 bb bb 167 Mär 30 10:25 scsynth.log
-rw-rw-r-- 1 bb bb 1670 Mär 30 10:25 spider.log
-rw-rw-r-- 1 bb bb 2486 Mär 30 10:25 tau.log
-rw-r–r-- 1 bb bb 5 Mär 30 10:25 tau_stdouterr.log

I actually run the flatpack version. I tried from many other sources and removed as these were not running properly.

Linux Mint 21.3 Virginia 64-bit is based on Linux-Kernel 5.15 and die Ubuntu 22.04- repository.
To my knoweledge the actual LTS Releases are:

I will install the latest Ubuntu and try again. I have a couple of 64-bit laptops remains from my active time here around.

I think there is a problem with the interfacing to SuperCollider, as the icons in qpwgraph are different between the different OS.

Thanks

some add on:
In Ubuntu 22.04 Pipewire is pre-installed out-of-the-box, and runs as background service automatically. But it must be activated for use. Indeed I hat to switch off puleaudio and replace by the pipewire-pulseaudio and wireplumber as describedin former postings.

Check in Terminal, in my case I get :
~$ systemctl --user status pipewire pipewire-session-manager
● pipewire.service - PipeWire Multimedia Service
Loaded: loaded (/usr/lib/systemd/user/pipewire.service; enabled; vendor pr>
Active: active (running) since Sat 2024-03-30 10:16:27 CET; 51min ago
TriggeredBy: ● pipewire.socket
Main PID: 1120 (pipewire)
Tasks: 2 (limit: 9216)
Memory: 15.5M
CPU: 41.141s
CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewi>
└─1120 /usr/bin/pipewire

… some many more lines follow

And Ubuntu throws a warning!
IMPORTANT: This is NOT officially supported by Ubuntu so far. It still may not work on some devices. Don’t do it on production machine!
But the check makes sure that pipewire is working properly in my case.

Let’s see the check on Ubuntu.

do you have a usb audio interface? I often use a cheap one from amazon and switch SP output to that which works pretty well. I use this on a RPi for output. As far as the icons go, the actual executable is scsynth but I find that my icons are labelled SuperCollider on RPI, Debiian and Ubuntu builds, so not sure why yours are different. Maybe significant.
Yes you can I think hack ubuntu 22.04 as far as the sound system goes to get pipewire going, but it is only official with the latest 23.10 release. I have built with this mainly because it is available as arm64 and I run it under UTM as a native build virtual machine on my M2 based Mac. The same for Debian bookwork which has an arm64 release. I don’t have ready access to an intel based PC to check out earlier versions any more.
It can be very frustrating trying to get the audio output working from SP and there are so many flavours of linux that differnt solutions are required. That is why at present the only one with some support is the RPi as this has known hardware and OS, and was the original home of the first versions of SP. Note version 4.5 will only build on 64bit machines as one external bit of software used is only available in 64 bit.
The script controlling the audio output is daemon.rb which is in the app/server/ruby/bin folder This tries to connect but expects to find Supercollider sources rather than scsynth. See the function run_post_start_commands around line 1277

For fun I attach a picture of my mac simultanously running Sonic PI 4.5 on Mac, Ubuntu 23.10 and Debian 12. The Debian 12 installce is outputing audio to a cheap plugin audio usb device, the Ubuntu uses built in MAc speakers.

For the posted screenshots I removed the usb audio interface to avoid the usual discussion if this is the reason for the malfunktion of SP 4.5.

I use different models of Behringer U-Phoria smaller or larger, with or withoud MIDI plugs. The quality is good for professional recording and the price “cheap” compared to other products with a “better name”. Check it with the spectrum analyzer of audacity (free and open source). Powered via USB makes to work with much easier.

To my regret I cannot use it with my Raspberry 400, the one with Raspberry 4 built into the keyboard. It will get a power-hickup with the additional power consumer. The “small” Behringers do not have any other power plug than the usb, the big ones with a couple of mike/instrument inputs etc. do. Same with the usb mixer/audio interfaces.

I did not try with the “common” Raspberry pi 4, but as you write it will work - or do your interfaces need a separate power supply.

SP obviously was and is centered on the ARM chips. I have not tried to install on 32 bit.

The Linux sound system indeed is very messy. Hopefully pipewire will smooth it out. I have installed latest Debian and found even SP 3.2.2 from repository not running/starting. Stopped it and installed Ubuntu 20.04.6 for further testing. May be Ubuntu has a broader user community?

Thanks for the hint: “The script controlling the audio output is daemon.rb which is in the app/server/ruby/bin folder This tries to connect but expects to find Supercollider sources rather than scsynth. See the function run_post_start_commands around line 1277”. May be I will check it if I find the time.

Thanks anyway, happy easter, regards

B. Bloechl

I ran up a new VM of the latest debian 12.5 this afternoon on my mac and installed SP using the current latest commit. I installed the listed packages in the BUILD-LInux.md file (I had to add git and curl both of which were necessary).
I ran the linux-build-all.sh script but had to amend it adding the environmental variable VCPKG_FORCE_SYSTEM_BINARIES=1 at the beginning of line 7 to read
VCPKG_FORCE_SYSTEM_BINARIES=1 "$(SCRIPT_DIR}"/linux-prebuild.sh "$0"
because I was using an arm based system.
Otherwise it built without hitch and ran straight away connected to audio.
EDIT
This new article has just been added on github
Building v4.5.0 on Linux · Issue #3353 · sonic-pi-net/sonic-pi · GitHub which you will probably find useful

Another working linux distro
ran up a virtual Fedora39 under UTM on my Mac and that installed a working sonic-pi 4.5 flatpak from the built in software app. (using Gnome desktop)

I tried to install SP 4.5 on a freshly installed ubuntu from Install Sonic Pi on Linux | Flathub
~$ flatpak install flathub net.sonic_pi.SonicPi

Note that the directories

‘/var/lib/flatpak/exports/share’
‘/home/bb/.local/share/flatpak/exports/share’

are not in the search path set by the XDG_DATA_DIRS environment variable, so
applications installed by Flatpak may not appear on your desktop until the
session is restarted.

Looking for matches…
Fehler: No remote refs found similar to ‘flathub’

Next install Debian an try agin.

No, that’s not so safe, it depends on whether the virtualization software simulates a complete computer with all components (including CPU, sound, etc.) or accesses the host components using its own drivers.

Tried both with host sound and also with external USB audio. I think most of teh problems arise from sorting out pipewire /pulse and audio routing.