Sound not working

So i downloaded sonic PI today, and started doing the guide thing, and when i tried to run the program no sound played, the scope didint show anything either.

Hi Nasko. What computer/operating system are you trying to run it on? Which version of Sonic PI? on.
if you look in your home folder there should be a folder .sonic-pi this contains a sub-folder with log files in it. It is helpful if you can post the contents of these to work out what is going

I’m using windows10, sonic pi v3.1.0

There haave been some sound issues with Windows and 3.1 posted both here and on github (Sonic Pi repository) recently. Usually they have result in Sonic Pi not starting at all, so yours is slightly unusual. Again the contents of the log files would be useful.

Okay, so i just check in the %appdata% folder?

Wait i think i found it

If you open File Explorer and click on “This PC” then on “Windws (C:)” you can then navigate to
Users -> <your user name -> .sonic-pi -> log
and you will see them listed. They are text files which can be opened with Notepad. Of particular interest will be the contents of scsynth, server-output and server-errors

Ok here you go:

scsynth:

Starting SuperCollider 2019-11-24 15:34:07

Device options:

  • MME : Microsoft Sound Mapper - Input (device #0 with 2 ins 0 outs)
  • MME : Microphone (Realtek High Defini (device #1 with 2 ins 0 outs)
  • MME : Microsoft Sound Mapper - Output (device #2 with 0 ins 2 outs)
  • MME : Speakers (Realtek High Definiti (device #3 with 0 ins 2 outs)
  • Windows DirectSound : Primary Sound Capture Driver (device #4 with 2 ins 0 outs)
  • Windows DirectSound : Microphone (Realtek High Definition Audio) (device #5 with 2 ins 0 outs)
  • Windows DirectSound : Primary Sound Driver (device #6 with 0 ins 2 outs)
  • Windows DirectSound : Speakers (Realtek High Definition Audio) (device #7 with 0 ins 2 outs)
  • ASIO : ASIO4ALL v2 (device #8 with 2 ins 2 outs)
  • ASIO : FL Studio ASIO (device #9 with 2 ins 2 outs)
  • Windows WASAPI : Speakers (Realtek High Definition Audio) (device #10 with 0 ins 2 outs)
  • Windows WASAPI : Microphone (Realtek High Definition Audio) (device #11 with 2 ins 0 outs)
  • Windows WDM-KS : Speakers (Realtek HD Audio output) (device #12 with 0 ins 2 outs)
  • Windows WDM-KS : Stereo Mix (Realtek HD Audio Stereo input) (device #13 with 2 ins 0 outs)
  • Windows WDM-KS : Microphone (Realtek HD Audio Mic input) (device #14 with 2 ins 0 outs)

Booting with:
In: MME : Microphone (Realtek High Defini
Out: MME : Speakers (Realtek High Definiti
Sample rate: 44100.000
Latency (in/out): 0.013 / 0.091 sec
SC_AudioDriver: sample rate = 44100.000000, driver’s block size = 64
SuperCollider 3 server ready.


server-output:

  • OK
    OSC MIDI in port: 4562
  • OK
    Started [13400] [-] “C:\Program Files (x86)\Sonic Pi\app\server\native\scsynth.exe” -u 4556 -m 131072 -a 1024 -D 0 -R 0 -l 1 -i 16 -o 16 -U “C:/Program Files (x86)/Sonic Pi/app/server/native/plugins/” -b 4096 -B 127.0.0.1 [-] C:/Users/VASILH~1/AppData/Local/Temp/sonic-pi-pids/13400
    Started [15324] [-] “C:/Program Files (x86)/Sonic Pi/app/server/native/erlang/bin/erl.exe” -noshell -pz “C:/Program Files (x86)/Sonic Pi/app/server/erlang” -s pi_server start 4560 [-] C:/Users/VASILH~1/AppData/Local/Temp/sonic-pi-pids/15324
    Started [9104] [-] ‘C:/Program Files (x86)/Sonic Pi/app/server/native/osmid/o2m’ -L -b -i 4561 -O 4562 -m 6 [-] C:/Users/VASILH~1/AppData/Local/Temp/sonic-pi-pids/9104
    Started [9224] [-] ‘C:/Program Files (x86)/Sonic Pi/app/server/native/osmid/m2o’ -b -o 4562 -m 6 ‘Sonic Pi’ [-] C:/Users/VASILH~1/AppData/Local/Temp/sonic-pi-pids/9224
    Booting server…

Booting Sonic Pi

Booting on Windows
Boot - Starting the SuperCollider server…
Boot - C:/Program Files (x86)/Sonic Pi/app/server/native/scsynth.exe -u 4556 -m 131072 -a 1024 -D 0 -R 0 -l 1 -i 16 -o 16 -U C:/Program Files (x86)/Sonic Pi/app/server/native/plugins/ -b 4096 -B 127.0.0.1
Boot - SuperCollider booted successfully.
Boot - Connecting to the SuperCollider server…
Boot - Sending /status to server: 127.0.0.1:4556
Boot - Receiving ack from scsynth
Boot - Server connection established
Studio - Initialised SuperCollider Audio Server v3.9.0
Studio - Resetting server
Studio - Studio - clearing scsynth
Studio - Studio - allocating audio bus
Studio - Studio - Create Base Synth Groups
Studio - Starting mixer
Studio - Starting scope
“C:/Program Files (x86)/Sonic Pi/app/server/native/erlang/bin/erl.exe” -noshell -pz “C:/Program Files (x86)/Sonic Pi/app/server/erlang” -s pi_server start 4560
Studio - Spawning o2m with:
‘C:/Program Files (x86)/Sonic Pi/app/server/native/osmid/o2m’ -L -b -i 4561 -O 4562 -m 6
Studio - Spawning m2o with:
‘C:/Program Files (x86)/Sonic Pi/app/server/native/osmid/m2o’ -b -o 4562 -m 6 ‘Sonic Pi’
Studio - Initialised MIDI subsystems
This is Sonic Pi v3.1 running on windows with ruby api 2.3.0.
Sonic Pi Server successfully booted.
Studio - Pausing SuperCollider Audio Server
Studio - Pausing SuperCollider Audio Server
Studio - Setting master volume to 1.1200000047683716
Studio - Setting master volume to 1.1799999475479126
Studio - Setting master volume to 1.2599999904632568
Studio - Setting master volume to 1.340000033378601
Studio - Setting master volume to 1.440000057220459
Studio - Setting master volume to 1.5399999618530273
Studio - Setting master volume to 1.6200000047683716
Studio - Setting master volume to 1.7200000286102295
Studio - Setting master volume to 1.8200000524520874
Studio - Setting master volume to 1.9199999570846558
Studio - Setting master volume to 1.9800000190734863
Studio - Pausing SuperCollider Audio Server
Exiting - shutting down scsynth server…
Sending /quit command to scsynth
Stopping OSC server…
Stopped OSC server…
Server is exiting.
Shutting down GUI…
Goodbye :slight_smile:


server-errors:

Hmm these all look reasonable. I assume you were moving the audio slider to get the master volume changes in the log.

Did you try something like
Play 72
In the sp window followed by pressing RUN.
EDIT
Did you also quit sonic pi or did it shut down itself?

i quit sonic pi, also i havent tried that

i just tried playing 72 and it worked, i can hear sound, but originally i tried running this:
live_loop :fibble do
sample :hd_haus, rate: 1
sleep 0.5
end

Ah the problem is that it is bd_haus not hd_haus so it wouldn’t work. Looks like your system is fine

Oh.
Sorry for the inconveniance.

No inconvenience. Happy to help you sort it out. I have often spent a long time wondering why something wouldn’t work only to find that it was a typo problem!!
Incidentally have a look at the
load_example function which will let you load examples without typing them in. If you type in load_example then press space bar you will get an autocomplete list from which you can choose an example.
Once that is in place you press run to load it. The you press run again to run it.

Oh, neat! thats cool.

1 Like

Ok enjoy learning Sonic Pi. Lots of fun ahead!