Sonic pi only produces white noise

Hey everyone.
I recently found about musical live coding and I tried to install sonic pi, but I found an issue: it only produces white noise.

I’m using PopOS (ubuntu based GnuLinux distro). I tried to install it in 3 ways to no success:
* Flatpak from the pop shop
* .deb from the pop shop
* sudo apt install sonic-pi

I think the problem is related to the link to SuperColider or to alsa.
Has anyone experienced this?

@Force4760 - although I personally am not sure exactly what the issue is here, it’s worth asking what versions of Sonic Pi the pop Shop has available. The most recent release version of Sonic Pi is 3.3.1.

While Linux is not officially supported for Sonic Pi, there are plenty of people who have had success getting it working - often by compiling it themselves too, so it’s worth having a go if you feel that would be possible. (I’m sure there are folks here who would be able to provide advice if necessary).

@robin.newman has previously suggested trying to get a build of 3.3.1 for Ubuntu installed and running on Pop OS - it may work for you, if the issue is specific to Sonic Pi itself?

Failing that, perhaps folks might have other ideas you can try to get things working :slightly_smiling_face:

Hey. Thx for the response.
I’m going to try to install the 3.3.1 ubuntu version.