Sonic Pi - Midi under Linux Mint 19.3

i tried everything i could find in the net, burned a couple of hours and cant get it run.
So now i am giving up for today. (frustrated)

The build-in sonic-pi is working, but its 2.10 and MIDI is not supported yet.
Upgrade packages are not available.

Then i tried the appimages (link found here in the forum)

It started, sound is coming, but midi is not working.
I am getting a “Errno::ECONNREFUSED”

I tried to build from source, but the dependencies didnt match.
so i installed cmake, ruby and more in higher versions.
I get it build.
But the programm is shutdown right after the start. I read something about “a version conflict in boost or supercollider” but cant figure out what it is or how i can fix this.

I am at a dead end. No idea what to do next or which way to go.

If someone has any idea, please say something.


linux Mint 19.3 is based on which ubuntu version ?

give maybe a try (not tested on linux mint )

1 Like

i did it…i formatted my complete PC to install Linux Mint 20, that is based on Ubuntu 20.04.
Backuped and recovered everything, installed everything again and than followed the Link and installed the .deb
And it worked!

Thank you
100.times do

1 Like

Glad it worked on Mint.

1 Like