Problem with sending OSC to Renoise

Hi! I’m having problems with OSC (via UDP) which I use to connect to Renoise on my laptop.

use_osc "", 12000
osc "/renoise/transport/start"
{run: 2, time: 0.0}
 └─ OSC ->, 12000, /renoise/transport/start, []

Of course, the first thought was: it’s a network configuration issue. But testing connection in Pd (Pure Data) gave positive results: everything works fine.


What am I missing? From the docs it’s not clear if there are any additional configuration regarding OSC.

Hmm. I installed a demo version of renoise on my iMac (running MacOSCatalina andalso running Sonic Pi 3.3.1) and tried your code which is correct. (I adjusted the ip address to suit). It worked perfectly as did teh associated stop command. I just made sure that I enabled the OSC server in teh renoise preferences, and set the port there to 12000 rather than the default value.

What OS is your renoise and your Sonic Pi running on? Which version of Sonic Pi are you using?

Hi, Robin, thank you for answering and bringing me confidence in my code :slight_smile:

I’m running Sonic Pi 3.3.1 on RPi and Renoise 3.3.1 (funny coincidence) on Linux. I’ve checked my network configuration multiple times, and that Pd patch is working from RPi.

It seems that when this checkbox is off Sonic Pi doesn’t send any messages. Which is confusing, as the name of the option implies incoming messages.


Yes I think you need at least the incoming OSC ticked which is a bit confusing. I usually work with both on.
You can always test OSC internally with something like:

use_osc "localhost",4560
live_loop :tx do
  osc "/test/me",1,2
  sleep 0.5

live_loop :rx do
  n = sync "/osc*/test/me"
  puts n