New version, work?

Hi, is the new version working for you guys?
I have a MacBook pro m1 with monterrey 12.4. I have installed the new sonic pi and it doesn’t work, it doesn’t pay attention to the snippets, I run a simple “play 60” and it doesn’t react, I run a sample and nothing. The last version that works is Beta 7.
Does anyone know why this could be happening to me?

Thanks in advance

Sorry you’re having issues. Please could you raise an issue on GitHub here: Issues · sonic-pi-net/sonic-pi · GitHub

Please could you include the full set of logs in ~/.sonic-pi/logs.

I’d also be interested to know if beta 8 worked for you.

sorry, I don’t know where to collect that information (~/.sonic-pi/logs.). As for version 8, it never worked for me either.


Thanks, we can take it from here over on GitHub.

1 Like

This is?

=> Welcome to Sonic Pi v4.0

=> Running on Ruby v3.1.2

=> Initialised Erlang OSC Scheduler

=> Initialised SuperCollider Audio Server v3.12.1

=> When you share
your work and ideas
freely with others
the whole world benefits.

=> Let the Live Coding begin…

=> Has Sonic Pi made you smile?

We need your help to fund further development!

Sonic Pi is not financially supported by
any organisation.

We are therefore crowdsourcing funds from kind
people like you using Patreon.

We need at least 1000 supporters to continue.
Currently we have 731 generous individuals.

Please consider becoming a Patreon supporter too,
and help us keep Sonic Pi alive:

Sam Aaron is creating the code-based music creation and performance tool Sonic Pi | Patreon

Sorry, this is the log in the GUI for users. I was referring to the debug logs created in the .sonic-pi/logs directory in your home directory. This folder is hidden by default in the finder, but you can easily access it from the terminal.