Sonic Pi not booting on MacOS Sonoma

Since updating my Macbook to Sonoma Sonic Pi does not start anymore. It´s not - visibly - crashing at startup, but the start screen never even shows up.
Any recommendations what might be the cause?

Hi @Gisbert,

A few questions:

  • which version of Sonic Pi are you trying to boot?
  • which version of macOS did you update from?
  • is your Mac Intel or Apple Silicon Powered?
  • if it’s Apple Silicon - are you using the arm64 build or the intel one?

Hi Sam,

  • I try to boot Sonic Pi version 4.5
  • which macOS version did I update from? I´m pretty sure it was Monterey
  • Intel

@Gisbert - please could you submit an issue over on GitHub - Issues · sonic-pi-net/sonic-pi · GitHub

It would be really useful if you could share the full logs found in ~/.sonic-pi/log.

I will do that. Thanks!
Logs are found in the library? Sorry, I need a bit more details where to access the logs.

If you open up a terminal and type the following:

open ~/.sonic-pi

You’ll see a familiar Finder window pop up with the contents of Sonic Pi’s data directory which is stored within your home directory. This is where Sonic Pi saves the content of your buffers and all your preferences so it can remember where you were when you open it again.

Inside that Finder window you’ll see the log direcory and inside there is a number of .log files - it’s these that I’d like if possible.


One thing to try before we move over to GitHub Issues is to reset your GUI config. Looking at your logs, everything seems to be booting fine - so I’m wondering if your window settings have somehow managed to get into a bad state.

You can easily reset this by deleting the gui-settings.ini file found in the config directory. You can either open the .sonic-pi Finder window using the command above and navigate or just type the following into your terminal to immediately delete that specific file:

rm ~/.sonic-pi/config/gui-settings.ini

Make sure Sonic Pi isn’t running when you delete it, then try and boot Sonic Pi again. Let me know if that helps at all…

Hi Sam,

consider my problem solved, I was just able to open Sonic Pi.
I removed a corrupted file of my wacom driver and it worked…


1 Like