Networked OSC not working


#1

This is my first post here so I may not fully understand the etiquette on this forum.

I have been experimenting with Robin Newman’s theremin designs and the Dual Ultrasonic version worked fine on my rasbpi and win 10 laptop. I then decided to try the Time of Flight sensor version and whilst I am getting data on to the laptop there are no OSC messages getting to Sonic Pi. The Networked OSC is enabled, the laptop is connected by ssh to the pi but there are no messages and the ip address on which it is listening is 169.254.166.255 and not 192.168.1.89 which is the laptop address. There are no cue messages coming through although I can see input to the laptop on a cmd window.

I read a post at the start of the year that seemed to have the same problem. I am running Sonic-Pi 3.1

I hope someone can help me?

Peter


#2

Hi Peter
Welcome to the forum. I am in a hurry just now, but I will post some ideas later today.


#3

Generally, a 169 IP address means that your computer wasn’t able to talk to a DHCP server. Usually that means that your router is wedged and needs to be rebooted, or that your Wi-Fi isn’t working at all. A good starting point is to reboot your router and your laptop.
Make sure that your laptop is working with network connection before starting Sonic Pi
You should get an ip appropriate to your local network (in this case 192.168.1.89). You can sometimes get a different address displayed if your laptop has two or more network connections, eg one on wifi and another via a wired network connection.
You can check whether OSC is working locally by sending an OSC message from Sonic Pi to itself.
eg

use_osc "localhost",4559
osc "/test",1234

If you run this you should see the received message in the cues log.
If you have Soinc Pi 3.0.1 on your Raspberry PI, you can also try sending an OSC message from that to your laptop

use_osc "192.168.1.xx",4559
osc "test2",1224

(adjust the xx to suit your laptop S.onic Pi address)

Hope some of these tests help to get it working


#4

Thank you for your suggestions. This is what I have done:

  1. Rebooted laptop and router. The laptop is using Wifi.
  2. The laptop seems to be talking to the pi as I can use an ssh session and receive range data on the laptop.
  3. Sent the message from Sonic-pi on the laptop to itself and received cue messages and log messages that seemed correct.
  4. Tried the pi, Sonic-pi to laptop test and it ran but nothing received on the laptop. The laptop Sonic-pi is still reporting a local ip address of 169.254.166.255, listening on port 4559.

regards Peter


#6

Hmm. I set up SP 3.1 on a virtual Windows 10 machine here and it worked OK, receiving external OSC messages. One possible gotcha that occrus to me is this. Have you ticked the box on the IO prefs screen that says Receive Remote OSC messages? That has to be ticked in addtion to the box Enable OSC server for things to work.
There IS a problem with external OSC with 3.1 which is that you can’t SEND remote OSC messages from 3.1 (It’s OK from 3.0.1) as Sam Aaron added a switch to prevent it in the Erlang Code as it was causing proboems with the Windows Firewall. I reverse this on my 3.1 (and 3.2dev) on a Mac, and it is possible to do retlatively easily.


#7

Thanks for the suggestions. Still no joy and the IO screen OSC options are all selected with Enable midi systems.

The saving thing is that system works fine when using Sonic Pi on the Rasp-pi!!

regards Peter