TouchOSC on iPad not connecting to SonicPi on Laptop

I can get TouchOSC on my laptop to connect with SonicPi on the same laptop, but I can’t get TouchOSC on my ipad to connect to SonicPi on my laptop. I’ve attached a screen shot.

I notice that you already have “Allow OSC from other computers” enabled, so that isn’t the problem.

Just checking, but the laptop and the iPad are on the same local network? And TouchOSC is configured to send to the correct IP and port ( in the screenshot)?

Is there some way you can test the connectivity between the two devices? (e.g. ping the laptop IP address from the iPad - not sure if that’s possible, maybe there’s an app for it).

Hm… well it certainly works with 3.3.1 because I use it all the time Which version of TouchOSC do you have? Version1 or the new one? It’s easy to get the addresses and ports mixed up.
My Mac is on ip

Here are the config screens for both versions of TouchOSC allowing connection.
My ipad is on ip, and both TouchOSC versions expect OSC messages on port 9000. They are both configured to send to my Mac on port 4560 at ip

Unless you are sending stuff back to touch OSC, you don;t need the use_osc line. I can’t see from your program if you are or not.

Thanks! Yes, the iPad and Laptop are on the same local network and TouchOSC is configured to send to the Laptop’s IP. I thought it might be the laptop’s firewall, but I turned that off and still the iPad didn’t seem to be connecting to the Laptop?

Thanks Robin!

Yes, the Laptop’s IP address is in the TouchOSC Host box with Send Port 4560.
I checked and I have TouchOSC which I believe is the latest? I also tried turning off my laptop’s firewall, but still no luck.
What is weird is I also have TouchOSC on my Laptop and it works fine, so it seems that somehow the wireless connection is not working? I’m rather stumped.

The ping test is working ?

It may be to do with external OSC via localhost OSC input. I seem to remember there was an issue with the flags on some early version. As a matter of interest, run SP, try switching off and then on again the external OSC flag and see if that makes any difference. Alternatively, you could try using the latest SP4.0.1 now available (although soon to be updated to 4.0.2)

ping test did not work. However, when I went home and tried on my home network the OSC connection was fine. I spoke to the IT person at my school today and he thinks it might be an issue with the router on the school’s network? So I guess the question is now that it seems there is something about the school’s network that is preventing a wireless connection from happening?

I’ll try updating to the latest SP - thanks!

It could be that the network has some sort of client isolation set up for security reasons (something like this).