Windows 10: Runtime Error Thread got too far behind time


#1

Hello there,
I am new to Sonic Pi. After a great Presentation from Sam in Eindhoven, I wanted to try for myself. So I installed Sonic Pi on my Windows 10 Machine. But unfortunately it won’t work. I keep getting Runtime Error, Thread got too far behind time. I already read somewhere that I might have something to do with power saving settings. I tried fiddling with those, but it will not solve the problems. Can anyone tell me what the magic buttons are to press, here?
Thanx,

Jelka


#2

Hi @jelka,

it is probably helpful to see some example of code where this happens.

Just copy the code, insert three backticks, return, then the code, return and three more backticks and it’ll be nicely formated for anyone to check (see Sam’s remarks about formating if my description is not clear enough).

Martin


#3

I’m getting the same error message. I’m a teacher and I’ve now installed Sonic-Pi on several computers in my school. While I’m in my administrator mode I am able to use Sonic-Pi (that’s how I have to install it), but when I switch to my regular account I get this exact error. Not on every computer but on some. It’s not the code. It can be as simple as “Play 70” and I get this error. I have uninstalled and re-installed the program twice. The data seems to remain. Meaning that when I re-start Sonic-Pi, the code, “Play 70” still appears. So maybe if I could clear the cache somehow, but I’m not sure how to do that. Help please!


#4

Sorry, I won’t be able to answer this question. Seems to be some problem with access rights and/or network. I guess there must be someone around here having experience with installing Sonic Pi in a similar environement.


#5

Thanks for the quick reply.


#6

Hi @luxo242,

I’ve recently switched to a Windows machine for my live performances. One thing I noticed is that I got unexpected timing errors until I disabled all the energy saving optimisations in the OS. Once I did, the errors stopped.

Are you running Sonic Pi on laptops? Perhaps you might want to try doing the same :slight_smile:


#7

I will try that. I’m not sure it’s the issue as it has happened both when plugged in an unplugged. It happened on another laptop (Windows 10) and I uninstalled and re-installed and it seemed to work after that. Is there a way to clear the buffer? On this computer when I re-installed Sonic-Pi, the code I had written previously was still there. So it’s not a complete wipe when it’s uninstalled. Some data clearly remains. Thank you.


#8

Hi @luxo242,

Sonic Pi stores preferences as well as the buffer states and logs within a .sonic-pi folder (here again, I am working not with Windows but probably something like C:\Users\[username]\AppData\.sonic-pi); if you delete that folder you’ll get a fresh Sonic Pi (it will create a fresh .sonic-pi folder after the initial start).


#9

I’m still not having any luck. I have changed the power settings to high-performance so there are no energy saving features on and it’s plugged in. I have found the log files and managed to delete them so when I load Sonic-Pi there is nothing there (although I notice some of my preferences were their, like the volume level). I re-installed and still get the same runtime error. I am going to uninstall, delete the logs and then pull the battery to see if that makes any difference. As you may have discerned, I’m not computer expert, but I can’t call the school boards IT department because it’s unsupported software. I’ll let you know how it goes.


#10

Still the same problem. Deleted everything. Uninstalled. Example:

=> Starting run 2

{run: 2, time: 0.0}

└─ synth :beep, {note: 50.0, cheese: 1}

=> Completed run 2

=> All runs completed

=> Pausing SuperCollider Audio Server

Doesn’t matter what I do I keep getting this error message. Ugh!