VMPK with loopMIDI trouble - Can't load SoundFont for FluidSynth

I tried following this guide:

I’m currently using Sonic Pi 4.3.0.

I can’t use the FluidSynth option. I get this message:

Information: wasapi: requested mode cannot be fully satisfied.

Error: fluid_sfloader_load(): Failed to open ‘’: File does not exist.

Error: Unable to open file ‘’

Error: Failed to load SoundFont “”

Looks like maybe it’s missing a filepath.
How do I overcome this?

This is rather an old article, and I think using a very early version of vmpk. You are right in saying that there is a sound font missing. I have just reinstalled vmpk which is now version 0.8.8 on a windows PC which I don’t use very much.
The easiest thing to do is to select Windows MM as the output driver and Microsoft GS Wavetable Synth as the Output midi connection.
Alternatively you have to track down a suitable .sf2 format soundFont which fluid synth can use. These can be quite hard to find as more modern versions .sf3 are now more common.
I suggest you try the FluidR3_GM.sf2 sound font and you can download the .sf2 version of this from here
Once downloaded and extracted move the .sf2 file to a convenient location and then load it into VMPK from the File Menu Import SoundFont…

A couple of other points have come to light when I tried this on a later version of Sonic Pi.
For simplicity in LoopBack make sure you just have one port named LoopMIDI Port setup
then start VMPK and setup the Midi connection as in the picture below.

As for Sonic Pi it automatically generates Midi ports for both input and output to loopMIDI
You want the one shown in Output which here is loop midi_port_2

When you load the sample midi file from the link in the original post there are a couple of changes you need to make.
First alter the port in line 4 to match what is shown in the Sonic Pi window here “loop midi_port_2”
Secondly, to make sure that all four channels have their instrument correctly selected change line 6 to read midi_pc 19, channel: [1,2,3,4]

Hopefully you can Get it going following this post. Let me know how it gores and. if you need further help.

Thanks for taking the time to investigate this for me.

The midi output from Sonic Pi into VMPK is now working for both MS GS Wavetable and the FluidSynth file you provided.

What I really want is to get midi input received into Sonic Pi. (I don’t have any physical midi instruments.) loopmidi_port_0 appears in the IO section of prefs, but typing on my qwerty keyboard when the VMPK window is selected or sliding over the keys with my mouse does not create any new /midi:.../note_on .../note_off cues in Sonic Pi.