Sonic Pi not recognizing my MIDI keyboard

I’m running Sonic Pi v3.2.0-dev-3538a on my Ubuntu system and it’s not recognizing my USB MIDI keyboard. Using aconnect and aseqdump, I was able to verify that my system recognizes it. I tried using qjackctl to route MIDI, but for whatever reason it can’t start up when sonic pi is running (and vice versa). It’s worth noting that aconnect doesn’t recognize sonic pi as an input or an output for MIDI.

System info:
Ubuntu 18.04.3 LTS

Did you check the I/O tab in SonicPi?
You explicitely have to activate MIDI. Then your device should show up in the list on the left.
Or does SonicPi detect other MIDI devices you have tried?

I did check the ‘enable midi connection’ box if that’s what you mean by ‘explicitly activate MIDI’. The available MIDI devices box doesn’t detect any MIDI inputs. I haven’t tried any other midi devices (I don’t own any other ones) though I suspect they wouldn’t work either since ALSA didn’t recognize Sonic Pi as a MIDI output when I tried to route the MIDI signal using aconnect