Sonic Pi Freezes if the internet connection gets interrupted

Hi All. I have been very apprehensive about downloading the latest version of sonic pi (3.3.1) because have been hearing it is a bit buggy (have been using 3.2.2 so far). In any case, downloaded it and turns out it might be true.

Was running some music and the program scope got stuck, and the audio cut out. I tried re running the code but to no avail so had to restart the program. Then just to test it out, I was running the session and purposely disconnected my internet and the program got stuck again (so I restarted it). Then (with no internet) it was running fine. Reconnected to the internet and it got stuck again.

Is there any remedy for this? If not, I am going to roll back to 3.2.2 cause that was working fine.

Hey there,

this is the first i’m hearing of behaviour like this. Judging from the error reports and feedback over the last 1.5 years v3.3.1 has been super solid. The only really buggy behaviour tends to occur on boot which is more of a factor of trying to get a piece of audio software working on a huge diverse range of hardware - which I’m always working to improve.

Please note that Sonic Pi does not require connection to the internet. It does, however, use the local loopback network to communicate with itself. It’s possible somehow that by disconnecting you also inhibited the local loopback network which definitely would break things.

If you do have a way of reliably reproducing an error then that’s definitely something that should be raised over in our GitHub issue: Issues · sonic-pi-net/sonic-pi (

1 Like

Hi Sam! Thanks for getting back to me so quickly.

Right now I am not sure how to get an error of this, since the program doesn’t throw me one (the scope just hangs, and then when I run the code, the log says its running the functions but it doesn’t go past that).

The local loopback network thing kind of makes sense to me so will look into it and see if I can stop it from happening.

Thanks, and do let me know if you find anything - really want to make sure you get things working. I should also note that v3.3.1 is pretty old now; we’ve been working on v4.0 for over a year now, which means many internal dependencies have been updated too. So, if it turns out to be an issue with one of them it’s possible v4 might solve it. v4 is currently only available to Patreon supporters, but it will be released just as soon as I’ve finished the last final missing pieces to the new Link functionality.

1 Like