Sample reproduction problem

Hi everyone
I have added a song inside the folder “Samples” provided with the program. I have tried to reproduce that song as a sample with the “classical” procedure: sample :filename. However, the sound doesn’t come out even though on the log window the program says that it is reproducing the file. Perhaps Sonic Pi has a limit for samples lenght?

The problem is that I would play along that song, and record the result directly from Sonic Pi.

Thanks everyone for the help.

I forget to say that I’m woking with Sonic Pi 2.11.1 on Windows.

There’s no sample limit as far as I’m aware (other than ram size).

However, rather than attempt to figure out why things aren’t working when you throw samples into the internal sample directory, it makes much more sense to show you the supported way. Have you read through sections 3.6 and 3.7 of the built in tutorial?

Let me know if that helps…

Sorry Sam,
I didn’t read those sections. Now I have tried to reproduce the sample following the instructions in the tutorial but it still does not work.

This is what I have typed:
sample "/users/giovanni/music/babelica.flac"
and then alt + r but anything comes out from the speakers…

the log shows this message
=> Studio: Resuming SuperCollider audio server

=> Starting run 14

=> Loaded sample “C:/Program Files (x86)/Sonic Pi/etc/samples/ambi_choir.flac”

{run: 14, time: 0.0}
└─ sample “C:/users/giovanni/music”,

=> Completed run 14

=> All runs completed

It seems that Sonic Pi sees the track but then it does not play it, as after a few moments it has started to run, it reports on the log that it has completed the run.

Any advice? Maybe converting the file in .wav could help?

Can confirm something similar to this issue. Converting to to .wav will not help.
I converted a large mp3 to wav (ending up at ~ 600Mb) and no sound occurs when I try to play it in Sonic Pi.

The log shows:

=> Starting run 1

=> Loaded sample "C:/Users/Ethan/Desktop/wavfileo.wav"

{run: 1, time: 0.0}
 └─ sample "C:/Users/Ethan/Desktop",
=> Completed run 1

=> All runs completed

=> Pausing SuperCollider Audio Server

In scsynth.log, after SuperCollider has booted up I see the line:

Buffer UGen: no buffer data

I’m not exactly sure whether it’s just because it takes a while to load it into memory, but I wouldn’t be surprised if it’s something like that. @samaaron may know more.

actually, I managed to make it work by converting the file in .wav and then playing the sample as external sond source, as you did…I have no idea what may be your issue, sorry