Non "pi" users and audio on the Raspberry Pi

Seems like every semester I attempt to do my Sonic Pi unit I run into something preventing it.
I have a cluster of RPi in my classroom. Students are accessing them via VNC, but since I’ve yet to find a reliable solution for streaming audio over VNC, through a non-admin account, they still need proximity and headphones.
They are using personal accounts, one user per RPi.
Today was supposed to be the unit start. I found that with their USB headphones (and analog) they could get sound from Audacity, but not from Sonic Pi. Their taskbars also exclude the volume control widget for selecting audio IO. I know if you switch audio out options you have to restart Sonic Pi. I did use the raspi-config interface to force the USB audio device, restart SP… still no sound. Same machine, if I VNC in as the pi user, I have access to the sound in SP.
Short of giving them access to the pi account, at least for this unit, what other things could I try out to get this working.
Their accounts are in the audio group, so I wasn’t surprised they could get sound from another app, but I was surprised SP wasn’t giving them audio output.
I did attempt to get sound from the analog headphones, assuming that possibly that was the default option already, but again, SP provided no sound output.
The RPi are running Raspbian Buster and Sonic Pi 3.2.2.
I know 4.x is out now, but something I read or tried prevented me from installing that version without undoing a lot of setup I had done previously.

Hi Chris
I think we’ve discussed some of your problems in previous years, so hopefully we can somewhere on this.
I’ve dug out an old Buster memory card with 3.2.2 on it and added a user student just assigned to group student and the additional group audio. I booted and logged in as the new user, selected usb audio out on the menu bar audio applet (make sure the usb device is pluggd in) and then started Sonic Pi and had no trouble loading and listening to one of the example programs, so the basic concept of working with an additional user is fine. Of course this still has the normal menubar and all apps available, so it now comes down to how you have restricted these, and what effect these restrictions may have had on the running of Sonic Pi. At a basic level hiding apps using the menu editor, or removing menu applets by right clicking the menubar and using add/remove panel applets shouldn’t affect things, although I would leave the volume control alsa/bt applet. Of course students can reverse these.
Without knowing specifics of how you have tweaked the OS it is difficult to say more.
However, I would strongly advise that if you have spent a long time reconfiguring the OS you consider moving to the latest OS and also using later versions of Sonic Pi where quite a lot of effort has gone into improving the audio selection. For example you can change audio output without having to restart Sonic Pi. At present it looks like the upcoming Sonic Pi 5 (technical previews already released for patreon supporters) will require 64bit Raspberry Pi OS latest version. I have the technical preview built and working on this.

Thanks Robin.
I have no idea what they can’t access the volume/device menu. I’ve not tweaked the OS at all, just added websockify and novnc to make up for inconsistent VNC access, adding user groups and default user spaces.
I do think my best option might be to start over, once the semester is over with a 64 bit OS and just reinstall everything, after taking more notes on what I’ve done to stay above water. :slight_smile:
For now, I’ve added a VNC login to the pi account they can access and that should solve the short term problem.
I appreciate the suggestions. Perhaps upgrading to the latest greatest 64 bit will also magically solve the bluetooth headset connections issues, where they “connect”, but don’t seem to actually be connected.
Good reminder to get on the patreon.