Any ideas to get sound out of Rasp 400 blue speaker?

Complete Noob to lunix and Rasp…can figure out how to get sound out of the thing? Just opened it up yesterday.

Speaker works with it (youtube) , but cant find any audio options. RTFM and tried to get through “that one post” but now I can’t even find it ?!?! From what I read its a bluetooth issue I’m imagining. But I’m janxed out about ASIO4all driver or something Pi400 is missing ???

Not new to DAWs and windows (Live, FL, and Reason) but this is new and I’m super curious.

Much help appreciated!

You mention nothing about it, but are you in fact trying to make sound with Sonic Pi here? What is the specific task you are trying to carry out?

(If this does in fact relate to trying to make sound with Sonic Pi, then as a start, we will need details such as the version of the Raspberry Pi OS, and of Sonic Pi, that you are trying to use.)


Always start with a wired headphones or speakers.
Settings are maybe near the speaker icon
See you

1 Like

Right…there is No physical Audio output jack on the Raspberry Pi400, as mentioned it appears to be a bluetooth issue (I am getting sounds with other application (i.e. YouTube)…I am running 3.3.1 of Sonic Pi. I loaded the tutorial “Bass Thump” and I see the Scope giving a steady beat…absolutely no sound. I close every other application down, same thing.

I don’t know how else to say it. Whatever, I tried. :frowning: Maybe try again when I’m more familiar with system.

Is this thread related to your issue, and might it help?

I have an Anker BT speaker which works OK with Sonic PI 3.3.1 on my Pi400 using the latest Raspberry Pi OS. It can be slightly finicky setting it up but it works.
I set the BT speaker up as the default audio before starting Sonic Pi. You first have to pair it using the bluetooth icon, then select it as default output by right clicking the speaker icon.
This is from memory. I’ll check it out again tomorrow morning. I normally use a techrise usb audio interface £7.99 from Amazon.
EDIT checked this morning and works OK. It can be a bit flaky. If the volume is too low you can install the package pavucontrol.
sudo apt install pavucontrol in a terminal.
Then start PulseAudio volume Control from the Sound Menu. On the Playback tab (with Sonic Pi running) you should see Loopback from Jack source (JACK_to_PulseAudio). You can move the slider a bit to the right to increase the volume.
I’ll put it on my to do list to produce a video showing the setup process.

Apologies if my reply came out wrong! Between everyone here, it sounds like we should hopefully be able to solve your Bluetooth issue :slightly_smiling_face::crossed_fingers:

Thanks all…think the post above by Mark is the solution from what I’m reading. Just have no clue what I’m doing or how to use anything. Like I said, no clue what I’m doing. Regardless, I’m resilient and will be back after I check out some other open source synths and stuff. So much to do…so little time.