No sound on Rpi4 on HDMI2 (Sonic Version 3.2.2)

I have a double monitor installation. The HDMI-2 has loudspeakers, so my sound configuration on Rpi4 is HDMI-2; I can get music through them (VLC player) but entering Sonic Pi and just writing Play 60 and Run, I can see the scope working but no sound comes out.
I previously worked with Sonic Pi on a Rpi3 and USB speakers which I activated via “qjackctl” but now I’m stuck.
I tried also by launching qjctl and selecting HDMI2 but … nothing

Hi Michele
I’ll take a look. Are you using the recently released Raspberry Pi OS ( 2020-05-27)? I know that some changes to sound selection have been made with this version. If not it may be worth while updating to this. I think you can do a

sudo apt update
sudo apt  full-upgrade

I will have a look on my Pi4 and try it with two monitors and see what happens.

I’m still using Raspbian (VERSION=“10 (buster)”) . It’s curious that I decided not to move to Raspberry Pi OS in case of incompatibility with Sonic.
Maybe it’s important to let you know that meanwhile I’ve connected USB loudspeakers and Sonic works through them.
Let me remember you that my monitor with loudspeakers is HDMI2


I may have related problem …
( Rpi 3B+ )
Just ( via Noobs ) made new SD .
Now no sound from Sonic - Pi .
I do not hear the pop and increase
in hiss while Sonic - Pi is starting …
as before .

If you are using the latest 3.2.2 deb file downloadable from then this is compatible with Raspberry Pi OS (32 bit version). I have a separate version under developement for the 64bit OS as well.

If you are using the 3.1 version supplied with Raspberry Pi OS then this has problems with sound on the latest OS. Version 3.2.2 should work on a 3B+ without problems.

Thank You !
Gives me sound , but screen is not right .
I ’ ll go back to Buster for now .

What’s wrong with the screen? Can you share a screenshot before you switch back?

Can’t screen shoot with PiOs because S Pi won’t let me get to
terminal … But here’s shot from camera … Note small buttons
for one thing plus total screen taken ( as noted )
edit: By not let me get to terminal I mean get to task bar or menu
( because of screen)

Try doing shift+alt+F. That will adjust it to fit your screen size. Sometimes the intial screen size can be a problem on certain resolutions and screen sizes. If you do shit+alt+F again (it is a toggle) the app window size may be better. I’ve been playing with two very disparate monitor screen geometries on hdmi 1 and 2 and this has helped.

shift+alt+F only slightly adjusts …
brings buffer list on and off screen
if I turn up transparency , I can see
the taskbar , but still not click …
Which model RPi are you using ?

edit: Duh … Obviously 4 ( 2 hdmi )
That may be the problem ? ( mine )
Model 4 will not recognize my monitors
for some reason … But I have not
tried with the new OS …
For my ( selfish ) purpose , your time
would be better spent making the
sound work on the supplied software ,
rather than " reinventing the wheel "

Hi @hitsware - there is a shortcut built into Linux (at least in the versions that I have used so far) that allows you to click and drag anywhere inside a window, so that you can access the window title bar or frame, if they have gone outside of the screen edges. Hold down the Alt key and click and drag the window.

Thank You Ethan

My problem fixed ( for now )
SPi works , though HDMI only .
Scroll down to ’ other changes ’


I want to confirm the different screen of Sonic Pi 3.2.2 . I have a Raspberry Pi 4, using one screen with HDMI (Linux raspberrypi 4.19.118-v7l+ #1311 SMP Mon Apr 27 14:26:42 BST 2020 armv7l GNU/Linux).

In Sonic Pi 3.1. I can’t find the tutorial anymore, in 3.2.2. it’s back. But all buttons are smaller and it starts fullscreen.

I was thinkering with sound, because I couldn’t get sound through my HifiBerry DAC. Since 3.2.2. crashed at start-up a few times, I went back to 3.1
EDIT: I tried 3.2.2. again and now my HifiBerry works (selected by right-clicking the sound-menu of Raspberry Pi), without QJackCTL.

Sound does now work with QJackCTL, but funny enough ONE time it worked by selecting the HifiBerry from rightclicking the sound-menu and choosing my HifiBerry (without using QJackCTL). After restart that didn’t work anymore.

(removing acound.src, modprobe snd_bcm2835, amixer (giving always “amixer: Cannot find the given element from control default”), alsamixer (giving the correct sound card), raspi-config (only giving HDMI or headphones as options), aplay -l also lists all soundcards including the HifiBerry, trying rpi-update (bad idea: then my soundcard dissappeared from the sound-menu), uncommenting the dtparam=xxx hardware interfaces in boot/config.txt, …)

I didn’t try the headphone output, since I didn’t by that HifiBerry not to use it :-). I don’t have audio on HDMI (I use a recoverd laptop-screen with a screendriver, no audio).

Just to let everybody know that, after some updates of Raspbian, my Sonic 3.2.2 now sends sound to HDMI2.

Good to hear. It is only since the latest update to Raspberry Pi OS that hdmi2 can be properly selected as an output audio route.
btw if you still run the Raspberry Pi supplied SP3.1 this will not select alternative audio sources and also unfortunately leaves an instance of jackd running when it quits. In that case you need to type killall jackd in a terminal window to enable an alternative instance (eg started with QjackCtl) to start.

Unfortunately ( with 3B+ anyways ) , headphone no
longer works . The right-click on volume icon appears
to select , but output stays on hdmi . For now I’ve gone
back to Stretch . ( Updating Buster morphs it into Pi OS )

I’ll try them my 3B+ with Raspberry Pi OS. Think it works OK. Again you need to use SP 3.2.2 The supplied 3.1 won’t work properly.

EDIT moved my SD card with Raspberry Pi 32bit OS from my Pi4 to a Pi3B+ and it switches between HDMI and Analog with no problem. (Obviously you have to quit and restart SP in between switching for it to be effective.)

For a moment disregarding S-Pi.
( In fact without S-Pi installed )
Audio out does not switch between
HDMI and headphone … Neither
with S-Pi ( I choose to use
3.0.1. because of the screen
( perhaps that’s the problem
( as far as S-Pi goes ) ) )