No log for a specific live_loop

Hi everybody,

i’m working on a project into spi and would like not to see every liveloop trace in the logs ?
Is it possible ?

Well, I’m working with 3.2 here, so you might see different…

If you go into prefs/editor and untick ‘Show cue log’ then
no live_loops are displayed.

Then you can put something like this in the loop you are
interested in ?

puts ‘Cued: Name of the live_loop’

Sound good?

Eli…

You can disable the cue from the live_loop with: live_loop :foo, auto_cue: false do ..., but this only works if you’re not using that cue for anything.

To disable the logs of synths being triggered within a specific live_loop use:

use_debug false

This needs to go within the live loop you want to silence (as is the case with all use_ fns).

For example:

live_loop :foo do
   use_debug false
   sample :bd_haus
   sleep 0.5
end

hi everybody,

Thank you for your answers. I’m using spi 3.2 under ubuntu 18.04.04.
Well sorry for disturbing you, I should have thought of the famous RTFM :slight_smile:
auto_cue: false is what i need but of course sam’s answer is usefull too.
See you

1 Like