Midi_pitch_bend at 8192 isn't zero bend in Omnisphere

As I read the documentation, doing

midi_note_on 36, port: OMNISPHERE, channel: 1

should play the same pitch as doing

midi_pitch_bend delta_midi: 8192, port: OMNISPHERE, channel: 1
midi_note_on 36, port: OMNISPHERE, channel: 1

because the documentation says, “No bend is central value 8192.”

That second one, though, is pitched below the first. Instead, this one gives the same as the first one:

midi_pitch_bend delta_midi: 16383, port: OMNISPHERE, channel: 1
midi_note_on 36, port: OMNISPHERE, channel: 1

And then, consistently,

midi_pitch_bend delta_midi: 0
midi_note_on 36

plays MIDI note 35.

Am I missing something obvious, or is Omnisphere quirky?

@blipson - I don’t know exactly why that might be happening, but I did a quick Internet search and saw the following - does this potentially apply to you? is it possible that Omnisphere’s pitch bend range has been altered?

1 Like

Yes, when I set the pitch bend ranges on a part to ± 1 semitone, then Omnisphere behaves generally more normally though I’m still not getting the pitch behavior I expect.

Feel free to elaborate on the behaviour you were expecting instead - feedback is definitely helpful :+1:

What I’m trying to do is systematically use pitch bend adjustments per note to play MIDI devices with microtunings. Omnisphere has microtunings built in, but I’m using it to develop this pitch bend-based algorithm.

Judging by ear, I can tell it’s not playing back the right pitches. Once it sounds close, I’ll look at the actual frequencies more directly.

1 Like

It could very well be that we have a bug with our pitch bend implementation given that we changed it in the last version. I’ll take a closer look too :slight_smile:

Actually, I’ve got it working now, and SPI’s pitch bend stuff works correctly as far as I can tell. Setting Omnisphere’s bend range to ±1 semitone makes sense, and I’ve just finished working out my own mistakes that were causing incorrect calculations.