Load_sample error (ogg) Format not recognised error with some files (RE-SOLVED)

Hi! I think there’s an issue with the bitrate or depth of samples I’m trying to play in sp, or something.

I’ve checked the syntax, and also tested with another test ogg with no issues

but the freesound ogg I wrote to file throws an exception.
Windows seems a little limited in information provided re depth and rate etc, but I also tried to get the lq as well as hq, in case the quality was the issue.

load_sample doesn’t seem to say there’s an issue, not sure if that’s expected behaviour.

I’ve added the file I’m unable to play in sp here

the syntax I’m using is sample "C:/Temp/fsogg.ogg"

Does anyone have any ideas?


I just discovered and optimistically attempted the sample_free_all prior to relaunch, but sadly that wasn’t the magic fix I was looking for.

On closer inspection I wonder if it’s the filetype within the ogg container that’s the issue (if that’s the right way of phrasing)

Freesound .ogg previews

This is actually the VORBIS format but it is used in conjunction with the ogg container, hence usually just called “ogg” or “ogg vorbis”. It is a lossy audio format but is said to have very good quality compared to other lossy audio formats, especially for low bit rates. More information can be found in the relevant wikipedia article Vorbis - Wikipedia

Also some media info, from VLC (sample rate matches that reported in SP.prefs)


Oops, worked out the mistake I’d made. VLC was downloading the file when I played it, it wasn’t local! :person_facepalming:t2:

Other similar issues stemmed from Incorrect case on filename, :bulb: use lowercase!