Install sonic pi 3.2 dev on ubuntu 18.04 LTS


#1

Bonjour, bonjour !

just an adaptation of this script https://github.com/samaaron/sonic-pi/blob/master/app/gui/qt/build-ubuntu-app.

git clone https://github.com/samaaron/sonic-pi.git
cd sonic-pi/

get the following script

place into ~/sonic-pi/app/gui/qt$

chmod +x build-ubuntu-18-04
sudo ./build-ubuntu-18-04
~/sonic-pi/app/gui/qt$ ./sonic-pi

Hope it works for you !
cheers


Read First - Welcome The Sonic Pi Community
#2

Hi. I’ve had some success with this but have no sound.
I’m on a fresh xubuntu 18.04 LTS virtual machine. Sonic-pi seems fine, but there’s no sound. Would you have any pointers to try?
I removed pulseaudio. No change but I don’t need it. Sonic-pi is the only thing I’ll use this vm for.
Tried looking at settings in jack through qjackctl… I’m lost.
Tried a sample in supercollider. Again, no sound.
Ideas?


#3

Hi @DavidMc,

as an introduction to how Jack/qjackctrl can be configured, I find this introduction useful.

Before that you should make sure that you can play and hear any sound at all. Can you? Then forget about the rest of this posting and try to set up Jack. You can use Audacious to check (in case there are still or other problems with Sonic Pi).

If no sound at all: You might start with speaker-test and aplay (something like aplay -D front foo.wav at the command line).

You definitely don’t have to remove pulse-audio to use Jack; it might even be better to have it until your sound works. It will be suspended once you start Jack (I might be able to give some advice at this point allthough I am not an expert).

I hope that does help a bit.


#4

Thanks, that did help. It led me down a path that at least got SP 2.10 working on my real machine. :slight_smile:

For Kubuntu 18.04 LTS :
sudo apt install sonic-pi sonic-pi-server-doc supercollider pulseaudio-module-jack
In qjackctl: Setup > Options: “Execute script after Startup:” pacmd set-default-sink jack_out

To run sonic-pi:
In qjackctl: Press Start
sonic-pi &

There’s probably a way to start jack directly but this works.
If I get brave, maybe I’ll have another shot at compiling SP3. Meanwhile it looks like 2.10 for me.

Thanks!


#5

@DavidMc: You might have already tried this, but maybe not: I don’t start Jack via qjackctrl; this did not work for me a while ago (never found out why) and so I created a - very simple - script called jack-internal, which I run. (Additionally I have an external audio device which, if pluged in, I trigger with another audio start script.)

It looks something like that for my internal soundcard:

#! /bin/bash
pulseaudio --kill &
jackd -d alsa --device hw:0 --rate 44100 --period 1024 & # internal soundcard
sleep 3
qjackctl --start &

This is called by another script e. g. audio-internal-sonicpi, which I adjust according to what I need. E. g.:

#! /bin/bash
pulseaudio --kill &
jack-internal &
sleep 1
a2jmidi_bridge &
sleep 1
sonicpi &
# start some softsynth or other things ...

Accordingly I do also have a stop script audio.stop to restart pulse-audio and quit Sonic Pi and other things:

#! /bin/bash
killall -9 sonicpi sonic-pi m2o o2m beam.smp ruby &
killall -9 qjackctl &
killall -9 carla &
#killall -9 helm &
sleep 3
exit

This can surely be done much more elegantly and more profoundly but so far it is a working and practical solution.