Alt-R not working

Hi all.
I’m finding the Alt-R key combination is not causing the code to run.
If I click the ‘run’ icon it works. But not the key combination.
Incidentally, the alt-S key combination does work.

Hi @StickManhattan - we’ll need a few more details to see if we can help. Which version of Sonic Pi and which Operating System are you using?

Yes of course, sorry.
Sonic Pi 3.1 running on Windows 10

No problem, that’s ok :slight_smile:
Interesting, I am running the same and it works fine. Does the code flash pink at all when you press Alt-R? what if anything actually happens when you try?

No - it doesn’t flash at all. Also this a Dell desktop. I’ve run it on my laptop previously (possibly an older Sonic Pi version) and it worked fine with windows 10.
Also, the alt-s combination for stopping works fine.

One other thing - it doesn’t type the character ‘r’ - i.e. if I hit alt-s it stops, if I hit alt-t it types the character ‘t’ (as there is no alt-t hotkey command I suppose), if I hit alt-r it doesn’t run or type r - so I’m guessing it does capture the command but doesn’t fulfill it (if that makes sense)

Is this a persistent problem? Does a reboot solve it?
Nothing else pops to mind immediately, but I’ll have a bit more of a think for sure. Hopefully you’ll eventually be able to get it running!

Reboot didn’t solve it.
It’s not urgent :slight_smile: the run button works with mouse click so thats ok.
Is there are repository I could download a previous version of sonic pi and test it?

Sure, all releases are at :+1:

(At least back to 2.1.0 anyway)

Ok - thanks. I’ll give that a try and let you know

1 Like

It seems my Alt-r combination is not working on any of my apps on my Dell Desktop. I tried on Reaper (my DAW) and it didn’t work.
I then tried Sonic Pi 3.1 on my laptop and the alt-r works fine.
So it really isn’t a Sonic Pi problem.
I used a key event viewer to analyse my keystrokes and the when alt-r is pressed I am not registering the ‘down’ stroke of the ‘r’ key.
It’s not sonic pi, it’s not my keyboard (i tested it on my laptop) so it must be something in my desktop setup that is causing it. It’s frustrating, but not a sonic pi problem so I won’t take up any more of your time - unless you have any ideas? Thanks anyway.

Alt-R does not work for me, either-- Sonic Pi 3.2.2, Windows 10.

We definitely need a way to customize these shortcuts.


Ah, problem solved— if you have an AMD Radeon card installed and are using the ‘Adrenaline’ drivers, it steals a bunch of shortcuts by default that are used for gaming. Disabling all the shortcuts via the AMD Radeon settings app does the trick.

Google saves the day. :slight_smile:



Yes I found that too - thanks :slight_smile: