'with fx :reverb' doesn't work


I wrote this example from the Sonic Pi tutorial in the buffer.

with_fx :reverb do
play 50
sleep 0.5
sample :elec_plip
sleep 0.5
play 62

But, if I write it without the ‘with_fx’, there is no difference in the sound.

play 50
sleep 0.5
sample :elec_plip
sleep 0.5
play 62

In both cases there is no reverb.
The other FX’s work. What could be the problem, and the solution for it?

Hi Pako,

That’s an interesting one. As far as I know, the reverb fx has worked for a while now.
Have you tried adding sustain: 0.5, release: 0 onto the ends of the play commands, (which would give them an abrupt cutoff), to make it easier to test the sound of the reverb?

(Incidentally, you may be able to make the reverb more obvious by increasing the value of the room opt - 0.6 is the default, but increasing it may help - for example):

with_fx :reverb, room: 1 do

Thanks for the answer, Ethan.

With the sustain I can’t make a difference. Seems, that the reverb-command doesn’t go in the played sound.
For example, I copy a code, that used the reverb, from the sonic-pi-site in my buffer, it sounds different.

But yes, when the room opt is 1, I can hear a reverb.

With the value ‘room 0.6’ or lower there is no reverb-effect. It sounds all the same.
The effect begins at ca. 0.8.

Hi Pako

The reverb effect is fairly subtle, and it’s meant as “seasoning” rather than a front-and-center audio changer. For that you’ll want to use gverb, which gives you a ton of options and a much more aggressive sound effect.


That’s nice, thanks, Chris.

I thought others might had similar experiences with the reverb. But it’s probably just my perception.