Sending MIDI Out to a Roland SP 404 SX

I’m trying to use a usb midi cable to hook my raspberry pi 4 to a Roland SP 404 SX and it’s not showing up under midi devices << I bought this cable here.

I’ve tried using a2jmidid and it shows up in qjackctl but not in sonic pi.

i’m not sure where I should go from here troubleshooting wise. The SP 404 is sorta weird in that it only has a midi in.

Is there any easy to use free software i could try to see if its recognized in other applications?

@rknutzen - are you attempting to use Sonic Pi 3.1?

Yes do I need a different version?

Yes, Sonic Pi 3.1 on Raspbian Buster does not fully work. See Sonic Pi 3.1 now on Raspbian Buster NOt FULLY WORKING for details of the issue if interested.
For a working version, see links in Sonic PI 3.2.2 deb file for Raspbian released.

1 Like

Thanks very much. downloaded the deb installed it with dpkg, then did

sudo apt --fix-broken install

and now it works great.

1 Like

Glad you got it goiing. In future easiest command line install that grabs dependencies is

sudo apt install ./path/to-sp-deb

NB the ./ before the deb