Really strange problem please help I'm unable to open files or set sonic pi to be the default app

hi everyone I’m having a very strange problem all of a sudden I’m unable to open files with sonic pi, and I’m unable to set sonic pi to be the default app to open files i’v tried changing folder permissions but still know luck anyone have any idea whats going on? your help with this problem would be most welcome kind regards trey.

Hi there,

how are you trying to open files with Sonic Pi? Are you using the load button in the toolbar? In the latest v3.2-beta1 release (which I believe you’re using) there’s also a new app menu File->Load and there’s also the shortcut Shift-Meta-o where Meta is the command button on macOS and alt on Windows.

With respect to setting Sonic Pi to be the default app to open files - this isn’t supported currently and isn’t likely to be something I’ll add in the short term. If something like this happens, it’s much more likely to be at the granularity level of ‘projects’. So you could load whole sets of buffers and ideally also their history and associated files.

I’ve tried using both the menu and shortcut I can find the files I want to load but the open button is greyed out :frowning:

Ah ok, that’s a much more specific issue which is easier to answer :slight_smile:

By default, there are filters on the file opening widget so that it only highlights and allows files with the extensions .rb, and .txt to be opened. It’s therefore likely that the file you would like to open has a different extension.

Regardless of extension name, it’s important to note that Sonic Pi will only open files that contain standard text.

If you wish to open a file with a different extension, you will need to use the drop-down filter menu which is visibly located above the “New Folder”, “Options”, “Cancel” and “Open” buttons - therefore I would assume the screen reader would read that out prior. The options for the file filters are:

  • Buffer files (*.rb *.txt)
  • Text files (*.txt)
  • Ruby files (*.rb)
  • All files (*.*)

You need to select All files (*.*) which will highlight and allow you to open files with any extension.

Do let me know if you have any issues with this.

no matter what type of files I set it to open it won’t open any the open button is still grayed out the files I’m trying to open are *.rb

I seem to have got it working I’ll keep you updated :slight_smile:

1 Like