Can't Open Sonic Pi 3.1.0... Error


#1

Can’t open Sonic Pi 3.1.0 after recently updated my Macbook. It’s giving me this error. I figure the issue is on account of me updating my computer as it was running smoothly about a week ago.

Here’s the bootup error printout:

Sonic Pi Boot Error Report

==================

System Information


  • Sonic Pi version: 3.1.0

  • OS: macOS 10.13

GUI Log


/Users/sheamkennedy/.sonic-pi/log/gui.log


[GUI] - Detecting port numbers...

[GUI] - GUI OSC listen port 4558

[GUI] - port: 4558 [OK]

[GUI] - Server OSC listen port 4557

[GUI] - port: 4557 [OK]

[GUI] - Server incoming OSC cues port 4559

[GUI] - port: 4559 [OK]

[GUI] - Scsynth port 4556

[GUI] - port: 4556 [OK]

[GUI] - Server OSC out port 4558

[GUI] - GUI OSC out port 4557

[GUI] - Scsynth send port 4556

[GUI] - Erlang router port 4560

[GUI] - port: 4560 [Not Available]

[GUI] - OSC MIDI out port 4561

[GUI] - port: 4561 [Not Available]

[GUI] - OSC MIDI in port 4562

[GUI] - port: 4562 [OK]

[GUI] - Init script completed

[GUI] - using default editor colours

[GUI] - launching Sonic Pi Server:

[GUI] - starting UDP OSC Server on port 4558...

[GUI] - UDP OSC Server ready and listening

[GUI] - Ruby server pid registered: 73664

[GUI] - waiting for Sonic Pi Server to boot...

...

[GUI] - Sonic Pi Server failed to start with this error message:

> Port unavailable: 4560, is scsynth already running?

[GUI] - UDP OSC Server no longer listening

.........................................................

[GUI] - Critical error! Could not boot Sonic Pi Server.

[GUI] - stopping UDP OSC Server...

Server Errors


/Users/sheamkennedy/.sonic-pi/log/server-errors.log


Server Output


/Users/sheamkennedy/.sonic-pi/log/server-output.log


Sonic Pi server booting...

Using protocol: udp

Detecting port numbers...

Send port: 4558

Listen port: 4557

- OK

Scsynth port: 4556

- OK

Scsynth send port: 4556

- OK

OSC cues port: 4559

- OK

Erlang port: 4560

Port 4560 unavailable. Perhaps Sonic Pi is already running?

Scsynth Output


/Users/sheamkennedy/.sonic-pi/log/scsynth.log


Process Log


/Users/sheamkennedy/.sonic-pi/log/processes.log


Clearing pids: ["72353"]

Clearing [72353]

-- command /Applications/Sonic Pi.app/Contents/MacOS/../../app/server/native/ruby/bin/ruby --enable-frozen-string-literal -E utf-8 /Applications/Sonic Pi.app/Contents/MacOS/../../app/server/ruby/bin/sonic-pi-server.rb -u 4557 4558 4556 4556 4559 4560 4561 4562

-- removing /var/folders/q0/cdnhfmcx67qgtr_0m6ym4y040000gn/T/sonic-pi-pids/72353

-- unable to get ProcTable info for: 72353

-- process: 72353 not running

Finished clearing pids

Started [73664] [-] /Applications/Sonic Pi.app/Contents/MacOS/../../app/server/native/ruby/bin/ruby --enable-frozen-string-literal -E utf-8 /Applications/Sonic Pi.app/Contents/MacOS/../../app/server/ruby/bin/sonic-pi-server.rb -u 4557 4558 4556 4556 4559 4560 4561 4562 [-] /var/folders/q0/cdnhfmcx67qgtr_0m6ym4y040000gn/T/sonic-pi-pids/73664


#2

Hi there,

it’s the nuclear option, but easiest - could you reboot your Mac and try again?


#3

That worked. Thanks again.


#4

This is becoming a bit annoying as I can only boot Sonic Pi after resetting my computer. Any time I close down the program I have to reset my computer again before I can open up the program again. I’ll be okay until this gets fixed, I just have to be careful not to close the program once I open it.


#5

Sorry to hear this, but unfortunately it’s not something I can replicate locally and you’re the only case I’m aware where this happens every time you stop Sonic Pi.

I therefore don’t have sufficient information to start to figure out what to fix and how to fix it.

How are you stopping Sonic Pi?


#6

I’m running it on a macbook with latest operating system. Turning Sonic Pi off by clicking the red “x” in the upper left corner of the window.


#7

Very strange, sorry you’re having issues.

I just started and stopped v3.1 of Sonic Pi 5 times in a row (using the red “x”) and it worked flawlessly. I’m also using the latest macOS 10.14.

Did this only start working with 10.14 or did you have this issue previously?


#8

The issue started on 10.14 as far as I know.