Building on Mac

I’ve been trying on and off for a long time to get Sonic Pi to build from source on my Mac, and could never get it to work properly. Then I recently saw Sam’s tweet and decided to give it another go.

Initially it failed because my system Ruby was too old - I’m still on Mojave which has 2.3.7, and the error message said it requires 2.4+. I had a newer version installed with Homebrew but it was not on the path, so after adding that to the path I tried again and the build completed and I was even able to open the newly compiled app with no errors (which is more than I’ve been able to do for a long time before).

However, after playing around with it a bit I’ve noticed that there are a couple of issues:

  • the scope window doesn’t show anything at all - it just stays completely black (in dark mode).
  • when I try to quit, it doesn’t shut down properly, and I have to force quit, which leaves some processes lying around (ruby, scsynth, beam.smp).

There are no errors or anything obviously unusual in the logs.

Does anyone have any ideas what could be up with either of the issues? Or just what to look at to get more information to help diagnose?

Hi @emlyn,

great that you’re playing around with building Sonic Pi yourself.

However, I must be clear to you and others on these forums that building the latest Sonic Pi from source is not the recommended way of using it - instead I highly recommend using the prebuilt, signed and fully tested releases. This will give you the most stable and reliable experience.

Building your own version definitely comes with caveats. As you have noticed, things won’t always be as stable and there are very likely to be bugs and other issues that either we haven’t yet discovered or got round to fixing yet. Also, new features that you find may also just disappear without warning. It’s often the case that I develop something, test it out then decide against it and remove it.

With respect to the issues that you mention, these have already been observed and hopefully fixed. I’d definitely recommend you update the sourcecode to the latest version and try again. There are a few other known issues (especially related to MIDI) but I’ll leave you to find them (unless we manage to fix them before you do :wink:

Finally, if you do find issues, I highly recommend you use the GitHub issue system to report and discuss them. That way it’s much easier for us to track them :slight_smile:

Good luck!

1 Like

Thanks for your reply! I fully understand the caveats - I use the released versions for anything requiring stability, but I also like to be able to try out bleeding edge features, or hack on things myself from time to time.

I didn’t post this on GitHub as I thought these were likely just issues with my setup, but I’m glad to hear they’ve been fixed in Sonic Pi - I can confirm that I’ve updated and these are now fixed for me!

If I find any other issues I’ll report them on GitHub.

1 Like

fwiw… I tried building it from source a few months ago as well on a Mac and didn’t manage to pull it off. I think I got bogged down with Qt errors before I quit.

@GenericJam you should try again now if you’re interested. Things are much more straightforward :slight_smile: