Build under ubuntu 19.04 DISCO

i think it’s not a good idea imho you should comment the exit line to let the user have a try. I do build script with less memory this afternoon but fails with the same rugged error.

Here’s a new version that forces rugged gem to be installed system wide, although I don’t understand why.
https://raw.githubusercontent.com/samaaron/sonic-pi/e207c1ce6c2d006a4d5a4fb7adbc3a75695f5054/app/gui/qt/build-ubuntu-disco-app

@nlb you can change the script as much as you want, but it looks like you didn’t compile it succesfully yet? :wink:

hi @mrvanes

well just to tell it works with less memory :wink: 2933 to be accurate.

image

cheers

Adjusted:

i bet we can do less :slight_smile: see you soon

La di da di sonic pi party!
@nlb @mrvanes thanks!

there some problems: sound out does not work, and after exit sonic pi get back to “light mode”.
is there any linux distro that sonic-pi 3 works flawlessly?

I had the same problem SP not persisting the dark mode and now don’t even get it to start due to some interprocess_exception error in boost I attributed to 3.2 being in heavy development right now. That’s why I stick to 3.1.0 for the moment (while using the synthdevs from 3.2, because they are broken ;))
@samaaron would you like us to report these problems on git or wait till it gets into more stable waters?

Ok, 3.2.0-dev start succeed when run as root, so there is some user access problem.
Correction, root also sometimes fails, so it seems a race condition.

Just tried the latest version of this installed on the SP github distro. Worked fine on a pristine Ubuntu 19.04 vm running on my Mac. Only minor problem is that I had to set the execute bit with chmod +x before running. On the pristine machine I also had to sudo pat install git to download the distro, but otherwise it was all in the script. I suppose I could have got a zip version instead :slight_smile: I also added qjackctl to make it easy to setup jackd as I wanted it.
It’s very similar to the build process I am using on Raspbian Buster on my Pi4.
Thanks for posting it.

Yeah, the bug was recently fixed by @samaaron and you’re right the +x is probably not set. You could have also sourced it of course… Nice catch about git, that’s so trivial I never thought it might not be installed on a pristine machine :wink:

Thank you all for making my life easier. Can’t wait to see what’s changed in the last 6 months.

EDIT: I don’t know if I should post as a bug or just warn the other couple of Ubuntu users. Closing via the quit menu option in ubuntu 19.04 (Mate w/ Studio) causes a core dump. After the core dump, I have to restart before I can run SPI again. Make sure to close via the window “X” to avoid this behavior.