Audio out changed


#1

I’ve used Sonic Pi in and education setting using Raspberry Pis for a few years now. As I get the kids coding, I have them use earbuds to hear their music, so we change audio out in Preferences. This time, using v. 3.0.1, I don’t see a way to change the audio out to the audio jack on the Raspberry Pi. I’m probably missing something obvious, but I don’t know where to change audio out. Any help would be appreciated.


#2

@hibdude

For some reason (not entirely obvious to me) Raspberry Pi specifically requested that I remove the audio selection from the preferences.

You can now change the audio using the standard selection system in Raspbian which unfortunately is a little hidden.

Heading to the Raspberry Pi documentation here:

You’ll find the relevant information:

Right-clicking the volume icon on the desktop taskbar brings up the audio output selector; this allows you to select between the internal audio outputs. It also allows you to select any external audio devices, such as USB sound cards and Bluetooth audio devices. A green tick is shown against the currently selected audio output device — simply left-click the desired output in the pop-up menu to change this.

I hope that this helps :slight_smile: