Receiving OSC from a monome/serialosc


#1

Hi

I am trying to use Sonic Pi with an old monome 40h (with serialosc)
I can get SP to send OSC to the monome and light LEDs etc., however I cant receive OSc from the monome. Nothing shows up in the cues window.

Does anyone know how to tell serialosc the correct port for SP?

thanks


#2

Just a thought. Have you enabled receive remote OSC messages on Sonic Pi IO prefs panel?

presumably you have read this site.

https://monome.org/docs/osc/


#3

thanks robin,

yes I’ve tried switching on the receive remote OSC prefs but with no joy.

Also I’ve tried sending messages direct to serialosc from SPi but i get nothing back. Somehow I need to get seriaosc to set the right destination port.


#4

Hi @whirecordings, to get the monome (via serialosc) to send messages to Sonic Pi, you must configure it to send to port 4559.

This can be done in one of two ways.

Edit config file

Firstly, you can edit the config file for your monome directly. This is stored in ~/Library/Preferences/org.monome.serialosc on macOS. Within that directory you should find a .conf file for your monome (or multiple files if you have multiple monomes). My file looks like this:

server {
  port = 15503
}
application {
  osc_prefix = "/monome/128"
  host = "127.0.0.1"
  port = 4559
}
device {
  rotation = 0
}

Note, that the application port has been set to 4559. This is the important part. Then you may need to reset serialosc to reflect the changes. By far the easiest way to do this is to restart your machine.

Talk via OSC API

The other approach is to dynamically talk to serialosc via the OSC API. This is documented here: https://monome.org/docs/osc/. This can be achieved using use_osc and osc in Sonic Pi. See their respective docs for further information.

I hope that this helps.

Finally, please do consider supporting further development (and support) for Sonic Pi on Patreon: https://patreon.com/samaaron


#5

Hi Sam,

Many thanks, thats exactly what i was looking for! Works now.
I changed the port number in the config file.

thanks again!