MIDI in on SP 3.2.0-dev/Linux


Yet another MIDI topic…

I tried to hook-up my Numark DJ2Go controller to see if I could detect cue events in my SP 3.2.0-dev on Linux 19.04, but no matter what I do, there’s no MIDI in device detected after enabling MIDI/OSC subsystems in SP and no cues when I hit the buttons or turn the knobs.
I did read through all (well, most) of the topics mentioning MIDI and I do see my controller appearing in qjackctl, the controller is available and working in mixxx DJ software, run as the same user and aconnect -i and -o both show the controller as an available MIDI device. I have o2m and m2o in ./app/server/native/linux/osmid which are identical to the ones built by the build script.
I also tried disabling jackd midi support and start a2jmidid, but that didn’t help either. It’s like SP is totally MIDI deaf in my build?

So now, I’m at a loss as to where to debug further?

Output of m2o and o2m tools:

$ ./m2o -l
Found 2 MIDI inputs.
   (0): DJ2Go MIDI 1
   (1): qjackctl

$ ./o2m -l
Found 1 MIDI outputs.
   (0): DJ2Go MIDI 1

Hi @mrvanes,

anything in the logs which could hint to missing midi?

Thx! For some reason the logs end up on my homefolder and they escaped my attention:

$ cat osmid_m2o.log  
sh: 1: exec: /home/martin/Tools/sonic-pi/app/server/native/osmid/m2o: not found

$ find -name m2o

It’s subtle, but ‘linux’ should be removed from the path, which can be explained by this line in the build-script:


And yay, I have cues!

 /midi/dj2go_midi_1/0/1/note_on  [71, 127]
 /midi/dj2go_midi_1/0/1/note_off  [71, 127]

Will fix and PR.