Install version 4 beta2 from sources on ubuntu 20.04.03

Hi,

if it can help, there is the history to install v4.0.0-beta2 from sources
Of course this is the latest version always in dev.

This process is for the version

commit 59931527e7e0c123d424585900bf8bcd6a3f6c6f (HEAD -> dev, origin/dev, origin/HEAD)

So here we go from a fresh ubuntu 20.04.03 dated 24/11/2021 install

sudo apt install git curl
mkdir spi-from-sources
cd spi-from-sources/

git clone https://github.com/sonic-pi-net/sonic-pi.git

then install some packages :slight_smile:

sudo apt-get install -y build-essential libssl-dev git ruby-dev elixir erlang-dev qttools5-dev qttools5-dev-tools libqt5svg5-dev supercollider-server sc3-plugins-server alsa-utils jackd2 libjack-jackd2-0 pulseaudio-module-jack librtmidi-dev cmake ninja-build
sudo apt-get -y install build-essential autoconf m4 libncurses5-dev libwxgtk3.0-gtk3-dev libgl1-mesa-dev libglu1-mesa-dev libpng-dev libssh-dev unixodbc-dev xsltproc fop

and some others

apt-get -y install build-essential autoconf m4 libncurses5-dev libwxgtk3.0-gtk3-dev libwxgtk-webview3.0-gtk3-dev libgl1-mesa-dev libglu1-mesa-dev libpng-dev libssh-dev unixodbc-dev xsltproc fop libxml2-utils libncurses-dev openjdk-11-jdk qtwebengine5-*

then we can build

 cd sonic-pi/app
 ls
 ./pi-install-elixir.sh 
 ./pi-build-all.sh 
  cd ..
  cd bin/
  ./sonic-pi   

I would like to thank @robin.newman for as always his precious help !
Hope it helps.

Cheers