Build under ubuntu 19.04 DISCO

cd ~/home/chip_luxury/sonic-pi/bin/

@nlb thanks, I manage to execute the commands as you can see at the down-right terminal.
The sonic-pi file run but there is a problem with line 20, I add a list of the folder it trying to get a file from, it does not seems that the file is there, or maybe I have a problem with the folder location?
do I needed to run “sudo apt-get install sonic-pi” after ubuntu installation or something like that?


First of all do you follow these steps

git clone
$ cd sonic-pi/app/gui/qt

Get the ubuntu-disco build script, make it executable and start it

Copy Code

$ wget
$ chmod +x build-ubuntu-disco-app
$ ./build-ubuntu-disco-app


If yes do you have error messages or not ?

ps : you don’t have to apt get install sonic-pi because the way to install is not via a package but via a script build-ubuntu-disco-app which contains plenty of commands to install pieces of software for sonic-pi to work.

The error you show just tells us the build never completed (there simply is no sonic-pi executable), probably because you’re missing a crucial package that we tinkerers for some reason all have installed. I can’t for the life of me think of what that should be unless you share (pastebin) the complete log of your build process. Would be good to know what’s missing on a vanilla dingo install.

update: You are missing libssl-dev for rugged. Install it like this:

$ sudo apt install libssl-dev

and then rerun the build.

I’ve updated the build script, it’s available from here:

It now also checks if you have enough memory, because I needed to add 4G to my VM before it succesfully built!

1 Like

@nlb this is with your code:
@mrvanes this is with copypaste of the script and run it in terminal:
I can also switch to another version of ubuntu if necessary…

Ok, I have seen that but didn’t know how to solve in the script. It’s ruby and gems and I don’t know what I’m doing there.
It seems for some reason my version of rugged (0.28.2) misses some magic so that the gem doesn’t get installed by the compile-extensions.rb script. You can solve this by hand this way:

$ cd ~/home/chip_luxury/sonic-pi/app/server/ruby/vendor/rugged-v0.28.2/
$ gem build rugged.gemspec
$ sudo gem install rugged

Maybe a ruby guru can look into this and tell me what’s missing after the clone I do to replace rugged?
Maybe the gem build command is all that’s needed, who will tell?

Anyway, after the commands above, the build will finally succeed, I promise :wink:

i think it’s not a good idea imho you should comment the exit line to let the user have a try. I do build script with less memory this afternoon but fails with the same rugged error.

Here’s a new version that forces rugged gem to be installed system wide, although I don’t understand why.

@nlb you can change the script as much as you want, but it looks like you didn’t compile it succesfully yet? :wink:

hi @mrvanes

well just to tell it works with less memory :wink: 2933 to be accurate.




i bet we can do less :slight_smile: see you soon

La di da di sonic pi party!
@nlb @mrvanes thanks!

there some problems: sound out does not work, and after exit sonic pi get back to “light mode”.
is there any linux distro that sonic-pi 3 works flawlessly?

I had the same problem SP not persisting the dark mode and now don’t even get it to start due to some interprocess_exception error in boost I attributed to 3.2 being in heavy development right now. That’s why I stick to 3.1.0 for the moment (while using the synthdevs from 3.2, because they are broken ;))
@samaaron would you like us to report these problems on git or wait till it gets into more stable waters?

Ok, 3.2.0-dev start succeed when run as root, so there is some user access problem.
Correction, root also sometimes fails, so it seems a race condition.

Just tried the latest version of this installed on the SP github distro. Worked fine on a pristine Ubuntu 19.04 vm running on my Mac. Only minor problem is that I had to set the execute bit with chmod +x before running. On the pristine machine I also had to sudo pat install git to download the distro, but otherwise it was all in the script. I suppose I could have got a zip version instead :slight_smile: I also added qjackctl to make it easy to setup jackd as I wanted it.
It’s very similar to the build process I am using on Raspbian Buster on my Pi4.
Thanks for posting it.

Yeah, the bug was recently fixed by @samaaron and you’re right the +x is probably not set. You could have also sourced it of course… Nice catch about git, that’s so trivial I never thought it might not be installed on a pristine machine :wink:

Thank you all for making my life easier. Can’t wait to see what’s changed in the last 6 months.

EDIT: I don’t know if I should post as a bug or just warn the other couple of Ubuntu users. Closing via the quit menu option in ubuntu 19.04 (Mate w/ Studio) causes a core dump. After the core dump, I have to restart before I can run SPI again. Make sure to close via the window “X” to avoid this behavior.

Hey SPI tweakers.

First of all, thank you for putting so much work into this amazing tool. This is my first post, so I definetely had to get that off my chest before coming at you with stupid questions.

I just did a fresh install of ubuntu 19.04 this afternoon and wanted to give setting up SPI up on linux another try. I have loaded the 3.1.0 version from git, renamed the folder to sonic-pi after unzipping and executed the latest version of the disco build script. I have also checked that libssl-dev is installed and enaugh memory is available. Anyways, I get stuck during the supercollider build (I believe). Specifically I get stuck at 69% at Linking CXX executable sclang. I have found the exact same error described here: . So I made sure that libqt5opengl5-dev and libqscintilla2-dev also installed, without success.

I have collected my output here:
To be honest, I am not understanding some of the further suggestions. I was hoping on a clean 19.04 ubuntu the disco build script would just kinda work “out of the box” as several people also reported :frowning: . Any help would be much appreciated.

Cheers, Justus

Exactly what it is about your setup that is causing this, I have no idea. (I don’t use Linux very often these days). I did some Googling for the errors in that console output, and saw this:
Although it may not be directly useful :man_shrugging:

welcome @jhuebotter

first i suggest you to forget ubuntu disco as this version will reach soon the end of life cycle (
For installation on linux, i suggest to search into this forum :slight_smile: . there are a lot of posts about this topic. Linux is not officially supported by sonic pi due to a lack of time (and money).
Good luck